Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 587551 - does not work with Huawei E220 3G usb modem
does not work with Huawei E220 3G usb modem
Status: CLOSED DUPLICATE of bug 597296
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-30 05:00 EDT by Andy
Modified: 2010-06-28 18:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 18:17:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy 2010-04-30 05:00:32 EDT
Description of problem:
Apr 30 10:30:21 andys-nb NetworkManager: <info>  modem manager disappeared


Version-Release number of selected component (if applicable):
NetworkManager.i686             1:0.8.0-6.git20100408.fc12   @updates           
NetworkManager-glib.i686        1:0.8.0-6.git20100408.fc12   @updates           
NetworkManager-gnome.i686       1:0.8.0-6.git20100408.fc12   @updates           
ModemManager.i686                0.3-9.git20100409.fc12                 @updates

How reproducible:
100%

Steps to Reproduce:
1.Update to latest with yum repos
2.Reboot if needed
3.connect USB modem
4.Configure using NetworkManager icon - right click - edit Connections - Mobile Broadband - add
5.NetworkManager icon - left click - Vodacom default 1
6.View /var/log/messages - see below

Apr 30 10:30:21 andys-nb NetworkManager: <info>  Activation (ttyUSB0) starting connection 'Vodacom Default 1'
Apr 30 10:30:21 andys-nb NetworkManager: <info>  (ttyUSB0): device state change: 3 -> 4 (reason 0)
Apr 30 10:30:21 andys-nb NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Apr 30 10:30:21 andys-nb NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Apr 30 10:30:21 andys-nb NetworkManager: <info>  Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Apr 30 10:30:21 andys-nb modem-manager: (ttyUSB0) opening serial device...
Apr 30 10:30:21 andys-nb modem-manager: Modem /org/freedesktop/ModemManager/Modems/0: state changed (disabled -> enabling)
Apr 30 10:30:21 andys-nb modem-manager: Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabling -> enabled)
Apr 30 10:30:21 andys-nb modem-manager: Modem /org/freedesktop/ModemManager/Modems/0: state changed (enabled -> registered)
Apr 30 10:30:21 andys-nb NetworkManager: <info>  modem manager disappeared
Apr 30 10:30:21 andys-nb NetworkManager: <info>  (ttyUSB0): now unmanaged
Apr 30 10:30:21 andys-nb NetworkManager: <info>  (ttyUSB0): device state change: 4 -> 1 (reason 36)
Apr 30 10:30:21 andys-nb NetworkManager: <info>  (ttyUSB0): deactivating device (reason: 36).
Apr 30 10:30:21 andys-nb NetworkManager: flush_routes: assertion `iface_idx >= 0' failed
Apr 30 10:30:21 andys-nb NetworkManager: flush_addresses: assertion `iface_idx >= 0' failed
Apr 30 10:30:21 andys-nb NetworkManager: <info>  (ttyUSB0): cleaning up...
Apr 30 10:30:21 andys-nb NetworkManager: <info>  (ttyUSB0): taking down device.
Apr 30 10:30:21 andys-nb NetworkManager: <info>  Trying to start the modem-manager...
  
Actual results:
Apr 30 10:30:21 andys-nb NetworkManager: <info>  modem manager disappeared

The process falls over in about 1 sec
The entry in the list of networks disapers
about 20 sec later is restored.

Expected results:
Connect to network

Additional info:
Comment 1 Dan Williams 2010-06-28 18:17:22 EDT

*** This bug has been marked as a duplicate of bug 597296 ***

Note You need to log in before you can comment on or make changes to this bug.