Bug 587576 - Cannot find new threads error when debugging programs that dlopen libraries.
Cannot find new threads error when debugging programs that dlopen libraries.
Status: CLOSED DUPLICATE of bug 179072
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-30 05:58 EDT by Tomas Mraz
Modified: 2010-04-30 06:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 06:07:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test source (224 bytes, text/plain)
2010-04-30 05:58 EDT, Tomas Mraz
no flags Details

  None (edit)
Description Tomas Mraz 2010-04-30 05:58:50 EDT
Created attachment 410354 [details]
Test source

Description of problem:
I'm trying to 

Version-Release number of selected component (if applicable):


How reproducible:
100% in F13 virtual machine hosted on F11 host.

Steps to Reproduce:
1. compile the attached program with make test CFLAGS='-g -O2' LDFLAGS='-lcrypto -g'
2. set breakpoint to main()
3. use next command to step over the FIPS_mode_set call
  
Actual results:

gdb prints:
(gdb) n
[Thread debugging using libthread_db enabled]
Cannot find new threads: generic error


Expected results:
to be able to continue debugging


Additional info:
You need to have undone prelink on libcrypto and libssl libraries. These libraries are dlopened during the FIPS_mode_set() call. The libcrypto is also DT_NEEDED so it does not cause anything during the dlopen() but when the libssl is dlopened it will break the debugging.
Comment 1 Tomas Mraz 2010-04-30 05:59:47 EDT
gdb version: gdb-7.1-16.fc13.x86_64
Comment 2 Jan Kratochvil 2010-04-30 06:07:51 EDT
Bug 179072 Comment 13 reproduces this specific problem.

*** This bug has been marked as a duplicate of bug 179072 ***

Note You need to log in before you can comment on or make changes to this bug.