Bug 587606 - Please install mergetools.rc as thgmergetools.rc
Summary: Please install mergetools.rc as thgmergetools.rc
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: tortoisehg   
(Show other bugs)
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mads Kiilerich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-30 11:23 UTC by Neal Becker
Modified: 2010-05-16 19:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-16 19:50:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Neal Becker 2010-04-30 11:23:36 UTC
Description of problem:

Refer to discussions on devel list.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mads Kiilerich 2010-04-30 12:48:03 UTC
Which discussion? Can you give a pointer to the archive?

Can you summarize the reasoning why it should be done? I would expect that the mergetool configurations rather should be merged upstream?

Comment 3 Mads Kiilerich 2010-05-16 19:50:11 UTC
I'm not fond of letting the tortoisehg package install a config file which also influences plain Mercurial. Further, this new config will merge with /etc/mercurial/hgrc.d/mergetools.rc. They could perhaps be synchronized, but that will not work if the user has customized the config.

The config has been merged into Mercurial upstream and will be released with 1.6.

If you want the diffargs config now then I propose that you backport the config changes from http://www.selenic.com/hg/rev/7d99edddbaea to the Mercurial package.


Note You need to log in before you can comment on or make changes to this bug.