Bug 587638 - Fontconfig's setting will replace wqy-zenhei with uming-fonts after install OpenOffice.org language package
Fontconfig's setting will replace wqy-zenhei with uming-fonts after install ...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-30 09:01 EDT by joshua
Modified: 2010-07-29 02:18 EDT (History)
7 users (show)

See Also:
Fixed In Version: openoffice.org-3.2.0-12.23.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 02:18:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joshua 2010-04-30 09:01:47 EDT
安装完Fedora 13 Livecd X86_64 Beta,系统默认的字体是wqy-zenhei,效果还不错。今天把这个 openoffice-langpack-zh_CN包装上,结果系统默认的字体立即自动变为Umingfonts了,反差真大,丑阿~~!我注意到在安装openoffice-langpack-zh_CN时,系统自动安装了*-Umingfonts 这个依赖包.
---------
可能是fontconfig配置让新安装的uming-fonts替换了默认的wqy-zenhei。
非常影响用户体验。希望得到修正。
Comment 1 joshua 2010-05-02 13:12:47 EDT
We know the default simplified chinese font of  Fedora 13 Livecd X86_64 Beta is wqy-zenhei,and it's very nice for most chinese users. But after I installed the package openoffice-langpack-zh_CN,The system's default font change to Uming fonts.It looks ugly.
I noticed that when installing openoffice-langpack-zh_CN,yum installed cjkuni-Uming-font due to package dependencies。
--------
Maybe the fontconfig's profile in /etc/fonts/conf.d let the Uming fonts loaded before wqy-zenhei.

When I removed cjkuni-Uming-font or deleted 64-ttf-arphic-uming.conf the default simplified chinese font change back to wqy-zenhei again.
-----
I think it's a bug  because I didn't found the same problem in Debian Squeeze.After  I installed cjkuni-Uming-font the default font in Debian  is still wqy-zenhei.

Thanks.
Comment 2 Peng Wu 2010-07-29 02:14:04 EDT
I think this is the same bug below:
Bug 589889 - update openoffice-langpack-zh_CN to not require uming
Bug 588132 - Fontconfig's setting will replace wqy-zenhei with uming-fonts after install OpenOffice.org language package

Please use "yum update" to use the lastest Fedora 13 packages, as the fixes is available on Fedora 13 updates, not in Live CD.
Comment 3 Parag Nemade 2010-07-29 02:18:05 EDT
Thanks Peng Wu for your comment. I think this can be closed then

Note You need to log in before you can comment on or make changes to this bug.