Bug 587640 - osad cannot be installed on rhel5 client, jabberpy and python-hashlib are missing in spacewalk tools repo
Summary: osad cannot be installed on rhel5 client, jabberpy and python-hashlib are mis...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Clients   
(Show other bugs)
Version: 1.1
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: space11
TreeView+ depends on / blocked
 
Reported: 2010-04-30 13:03 UTC by Petr Sklenar
Modified: 2012-03-06 09:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 14:27:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Petr Sklenar 2010-04-30 13:03:44 UTC
Description of problem:
osad has in deps jabberpy and python-hashlib, both are not in client tools repo for RHEL5.

jabberpy not in http://download.devel.redhat.com/qa/rhts/lookaside/spacewalk-nightly-client/el5/x86_64/os/
jabberpy not in http://spacewalk.redhat.com/yum/1.0-client/RHEL/5/x86_64/

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
[root@dhcp71-194 first-sanity-test]# yum install osad rhnsd rhn-setup rhn-client-tools -y
Loaded plugins: rhnplugin, security
beaker-distro1                                                                                                                       | 1.1 kB     00:00     
beaker-distro2                                                                                                                       | 1.1 kB     00:00     
beaker-distro3                                                                                                                       | 1.1 kB     00:00     
beaker-distro4                                                                                                                       | 1.1 kB     00:00     
customrepo1                                                                                                                          |  951 B     00:00     
rhts-noarch                                                                                                                          |  951 B     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package osad.noarch 0:5.9.32-1.el5 set to be updated
--> Processing Dependency: python-hashlib for package: osad
--> Processing Dependency: jabberpy for package: osad
--> Processing Dependency: PyXML for package: osad
--> Processing Dependency: rhn-client-tools = 0.4.20-33.el5 for package: rhn-check
---> Package rhn-client-tools.noarch 0:1.1.2-1.el5 set to be updated
--> Processing Dependency: python-ethtool for package: rhn-client-tools
---> Package rhn-setup.noarch 0:1.1.2-1.el5 set to be updated
---> Package rhnsd.x86_64 0:4.9.3-1.el5 set to be updated
--> Running transaction check
---> Package PyXML.x86_64 0:0.8.4-4.el5_4.2 set to be updated
---> Package osad.noarch 0:5.9.32-1.el5 set to be updated
--> Processing Dependency: python-hashlib for package: osad
--> Processing Dependency: jabberpy for package: osad
---> Package python-ethtool.x86_64 0:0.3-5.el5 set to be updated
---> Package rhn-check.noarch 0:1.1.2-1.el5 set to be updated
--> Finished Dependency Resolution
osad-5.9.32-1.el5.noarch from spacewalk-client-repo has depsolving problems
  --> Missing Dependency: jabberpy is needed by package osad-5.9.32-1.el5.noarch (spacewalk-client-repo)
osad-5.9.32-1.el5.noarch from spacewalk-client-repo has depsolving problems
  --> Missing Dependency: python-hashlib is needed by package osad-5.9.32-1.el5.noarch (spacewalk-client-repo)
Error: Missing Dependency: python-hashlib is needed by package osad-5.9.32-1.el5.noarch (spacewalk-client-repo)
Error: Missing Dependency: jabberpy is needed by package osad-5.9.32-1.el5.noarch (spacewalk-client-repo)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

[root@dhcp71-194 first-sanity-test]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.5 (Tikanga)

[root@dhcp71-194 first-sanity-test]# cat /etc/yum.repos.d/spacewalk-client-repo.repo 
[spacewalk-client-repo]
name=spacewalk-client-repo
baseurl=http://porkchop.redhat.com/qa/rhts/lookaside/spacewalk-nightly-client/el5/x86_64/os/
gpgcheck=0

  
Actual results:
missing jabberpy and python-hashlib

Expected results:
there are jabberpy and python-hashlib in repo for RHEL5

Additional info:

Comment 1 Milan Zázrivec 2010-04-30 14:18:45 UTC
I'm sure you'll be able to install those packages with EPEL-5
repo enabled.

Comment 2 Jan Pazdziora 2010-05-05 14:02:43 UTC
Taking.

Comment 3 Jan Pazdziora 2010-05-05 14:27:41 UTC
I've now amended the item 2 in https://fedorahosted.org/spacewalk/wiki/RegisteringClients#CentOS5orRedHatEnterpriseLinux5 to recommend EPEL.


Note You need to log in before you can comment on or make changes to this bug.