Bug 587662 - OSError: [Errno 2] No such file or directory: '/mnt/sysimage//mnt/source'
OSError: [Errno 2] No such file or directory: '/mnt/sysimage//mnt/source'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
anaconda_trace_hash:7720f089150cf6a05...
:
: 590637 (view as bug list)
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-04-30 09:55 EDT by James Laska
Modified: 2013-09-02 02:48 EDT (History)
11 users (show)

See Also:
Fixed In Version: anaconda-13.40-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 02:55:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (497.83 KB, text/plain)
2010-05-01 18:21 EDT, Richard Shaw
no flags Details

  None (edit)
Description James Laska 2010-04-30 09:55:53 EDT
Description of problem:

anaconda 13.37.2 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/__init__.py", line 1744, in fsFreeSpace
    if os.statvfs(path)[statvfs.F_FLAG] & ST_RDONLY:
  File "/usr/lib/anaconda/storage/__init__.py", line 1152, in fsFreeSpace
    return self.fsset.fsFreeSpace()
  File "/usr/lib/anaconda/backend.py", line 158, in mountInstallImage
    free = anaconda.storage.fsFreeSpace
  File "/usr/lib/anaconda/yuminstall.py", line 904, in run
    if self.anaconda.backend.mountInstallImage(self.anaconda, stage2img):
  File "/usr/lib/anaconda/yuminstall.py", line 1703, in doInstall
    rc = self.ayum.run(self.instLog, cb, anaconda.intf, anaconda.id)
  File "/usr/lib/anaconda/backend.py", line 299, in doInstall
    return anaconda.backend.doInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1313, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1334, in handleRenderCallback
    self.currentWindow.renderCallback()
OSError: [Errno 2] No such file or directory: '/mnt/sysimage//mnt/source'


Version-Release number of selected component (if applicable):
 * anaconda 13.37.2

How reproducible:
 * 3 autofilled bugs incorrectly linked to bug#565879

Actual results:

* see attachment#408966 [details]
* see attachment#410292 [details]
* see attachment#410112 [details]
* see attachment#409010 [details]

Expected results:

* No exception

Additional info:
Comment 1 James Laska 2010-04-30 10:10:51 EDT
Anne, Steve, Norm and cpg: this failure was reported against F-13-Beta.  Can you confirm the steps to reproduce this bug using the latest F-13 install images?  

Live images, and CD/DVD/netinst.iso media is available at http://serverbeach1.fedoraproject.org/pub/alt/stage/13.TC1
Comment 2 Chris Lumens 2010-04-30 10:51:17 EDT
Can anyone who is seeing this problem please try adding updates=http://clumens.fedorapeople.org/587662.img to their command line arguments?
Comment 3 James Laska 2010-04-30 11:18:31 EDT
(In reply to comment #2)
> Can anyone who is seeing this problem please try adding
> updates=http://clumens.fedorapeople.org/587662.img to their command line
> arguments?    

Positive test results using the posted updates.img.  Thanks clumens and steved.  Anyone else, your feedback is still valuable.

11:12:37   steved: clumens: btw... that update you gave me worked! thanks!
11:13:03   clumens: steved: fantastic.
Comment 4 cpg 2010-04-30 22:34:08 EDT
This fix in TC1 appears to work in VMware now.
Also i can add extra repositories in the net (which I could not in the beta).

All good!
Comment 5 cpg 2010-04-30 22:35:30 EDT
Just to clarify: I did not add the updates=http://clumens.... img.
Just the TC1 i386 iso tested.
Comment 6 cpg 2010-05-01 03:39:15 EDT
FWIW, this happened again on a new install on that TC1 image, so the issue is still there.

However, I did a number of things when it failed, and I cannot replicate it ... I don't know what combination of things I did, but i did click on "Fedora 13 - i386 - Test Updates" and unclicked it.

Anyway, the point is that this issue appears to be not entirely gone.
Comment 7 Richard Shaw 2010-05-01 18:21:20 EDT
Created attachment 410734 [details]
Attached traceback automatically from anaconda.
Comment 8 Richard Shaw 2010-05-01 18:25:20 EDT
(In reply to comment #7)
> Created an attachment (id=410734) [details]
> Attached traceback automatically from anaconda.    

To add to my automatic BZ entry:

Attempting to install TC1 x86_64 in Virtualbox. I tried just checking "Testing Updates" and it could not satisfy all the dependencies. Went back and checked the main repo and then ran into the bug.
Comment 9 Adam Williamson 2010-05-03 17:22:19 EDT
Clearly this is not yet fully fixed, re-assigning.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Chris Lumens 2010-05-03 17:29:38 EDT
> Clearly this is not yet fully fixed, re-assigning.

Based on what?  Did you look at the traceback in comment #7?  I did, and it says:

anaconda 13.39 exception report

Then let's look at what version I had in the Fixed In: field:

anaconda-13.40-1 

Last I checked, 13.40 is newer than 13.39.  Therefore you cannot say it's not fully fixed based on anything in comment #7.  Putting back into MODIFIED until actual evidence that it's not yet fixed is attached.
Comment 11 Adam Williamson 2010-05-03 21:06:46 EDT
it might've helped to add a comment noting that an updated fix had been pushed, but sorry. just the version field is a rather subtle hint.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Fedora Update System 2010-05-05 01:16:08 EDT
anaconda-13.40-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.40-1.fc13
Comment 13 Fedora Update System 2010-05-05 03:22:39 EDT
anaconda-13.40-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/anaconda-13.40-1.fc13
Comment 14 Adam Williamson 2010-05-05 12:58:26 EDT
We should now be able to confirm that this bug is fixed using the images here:

http://alt.fedoraproject.org/pub/alt/stage/13.0505/Fedora/i386/os/images/

if we have not yet confirmed the fix, can anyone able to reproduce this bug please test with one of those images and check that the bug is fixed? Thanks.
Comment 15 Fedora Update System 2010-05-06 02:54:43 EDT
anaconda-13.40-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Hans de Goede 2010-05-10 08:48:05 EDT
*** Bug 590637 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.