Bug 587714 - [RFE] Add MLDv1 / MLDv2 snooping to bridge [NEEDINFO]
[RFE] Add MLDv1 / MLDv2 snooping to bridge
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Herbert Xu
Jianlin Shi
Jana Heves
: FutureFeature
Depends On:
Blocks: 767187 1366045 838117 846704 1270638 1274135 1359574
  Show dependency treegraph
 
Reported: 2010-04-30 12:31 EDT by Subhendu Ghosh
Modified: 2016-10-04 00:32 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
MLDv1 and MLDv2 snooping added to bridge With this update, the bridge module adds support to IPv6 multicast by snooping for MLDv1 and MLDv2. Now, IPv6 multicast messages are sent only to ports with subscribed multicast receivers.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-25 09:54:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
herbert.xu: needinfo? (sghosh)


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2010-04-30 12:31:14 EDT
Description of problem:

The bridge module recently added support for IPv4 multicast by adding support for IGMP snooping. This request is to extend that support to IPv6 multicast by snooping for MLDv1 and MLDv2 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:

IPv6 mulicast message are broadcast on all ports

Expected results:

IPv6 multicast messages are only sent to ports with multicast receivers.

Additional info:

May require additional support in bridge-utils
Comment 9 Herbert Xu 2015-12-15 03:55:44 EST
Subhendu, it looks like RHEL6 already has the MLD snooping support courtesy of https://bugzilla.redhat.com/show_bug.cgi?id=716263

Can you please verify that this fulfills your needs? Thanks!
Comment 10 Linda Wang 2016-08-25 09:54:49 EDT
See comment#9. The feature seems to be already in
RHEL6; therefore, close as CURRENTRELEASE.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.