Bug 587733 - subscription-manager-cli is unable to display unicode
Summary: subscription-manager-cli is unable to display unicode
Status: CLOSED DUPLICATE of bug 590094
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin   
(Show other bugs)
Version: 0.5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Pradeep Kilambi
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-30 18:03 UTC by James Bowes
Modified: 2015-05-14 15:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-25 15:01:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Bowes 2010-04-30 18:03:15 UTC
Against either candlepin hosted or standalone, set your LANG env var to de_DE and run subscription-manager-cli register with a bad username/pass combo (for standalone you'll have to edit your config to include an auth line).

Results:
UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 23: ordinal not in range(128)

Expected:
A nice message in german about invalid username/password.

Note that the gui handles this fine, as does the log entry.

Comment 1 James Bowes 2010-05-25 15:01:02 UTC

*** This bug has been marked as a duplicate of bug 590094 ***


Note You need to log in before you can comment on or make changes to this bug.