Bug 587741 - Empty Trash doesn't really empty the trash
Empty Trash doesn't really empty the trash
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-mapi (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-30 14:30 EDT by Chad Feller
Modified: 2010-05-03 06:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 06:12:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 617509 None None None Never

  None (edit)
Description Chad Feller 2010-04-30 14:30:39 EDT
Description of problem:
File->Empty Trash doesn't really empty the trash.  Using OWA, when browsing folders I realized that my "Deleted Items" folder was full of messages that should have deleted.

Version-Release number of selected component (if applicable):
evolution-2.30.1-2.fc13.x86_64
evolution-mapi-0.30.1-1.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. Delete message in evolution
2. File->Empty Trash
3. View Deleted items folder in OWA
  
Actual results:
Deleted items folder still contains messages that should have been deleted

Expected results:
Delted items folder should be empty.

Additional info:
Comment 1 Chad Feller 2010-04-30 16:20:12 EDT
Browsing to the "Deleted Items" folder in Evolution also shows the same messages that are visible in OWA (I just didn't realize the bug until I was in OWA), but "Empty Trash" still has no effect, even if you are in the Deleted Items folder on Evolution.
Comment 2 Chad Feller 2010-04-30 16:34:49 EDT
Workaround:
right click on the "Deleted Items" folder (from the left folder navigation pane) and select "Empty Trash".  

So while File->"Empty Trash" does not work, right clicking on the folder and selecting "Empty Trash" does.  

Final note, when this account was configured for IMAP access (under F11, and F12), File->"Empty Trash" did work.  So this would seem to be an issue that only appears with the mapi connector.
Comment 3 Milan Crha 2010-05-03 06:12:45 EDT
Thanks for a bug report. I can reproduce it too. It seems to me that the issue is really only with evolution-mapi, and the reason seems to be that the summary for the "Deleted Items" folder isn't downloaded (you indicated that you didn't look in the folder earlier), thus evolution-mapi thinks there is no message stored in it, and skips the expunge operation. When you select it, it fetches folder summary, knows about messages, and the same expunge operation may work properly.

I'm moving this upstream. See [1] for more updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=617509

Note You need to log in before you can comment on or make changes to this bug.