Bug 587784 - [abrt] crash in NetworkManager-gnome-1:0.8.0-8.git20100426.fc12: Process /usr/bin/nm-connection-editor was killed by signal 11 (SIGSEGV)
[abrt] crash in NetworkManager-gnome-1:0.8.0-8.git20100426.fc12: Process /usr...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
abrt_hash:8ecf7a287712798e6b290c89ba9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-30 16:47 EDT by Matt McCutchen
Modified: 2010-09-26 00:35 EDT (History)
1 user (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-26 22:34:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (28.50 KB, text/plain)
2010-04-30 16:47 EDT, Matt McCutchen
no flags Details

  None (edit)
Description Matt McCutchen 2010-04-30 16:47:18 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/nm-connection-editor
component: NetworkManager
executable: /usr/bin/nm-connection-editor
global_uuid: 8ecf7a287712798e6b290c89ba984a5d48dcfe3f
kernel: 2.6.32.12-114.fc12.x86_64
package: NetworkManager-gnome-1:0.8.0-8.git20100426.fc12
rating: 4
reason: Process /usr/bin/nm-connection-editor was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

comment
-----
The crash happened when I clicked "Edit" on a VPN connection in the connection editor.

Possibly relevant: Yesterday, I changed the saved password for that VPN using the connection editor, and I have not used the VPN since then.  Now, if I open the "VPN password secret" entry in seahorse, the password text field is empty and uneditable (weird).
Comment 1 Matt McCutchen 2010-04-30 16:47:20 EDT
Created attachment 410596 [details]
File: backtrace
Comment 2 Matt McCutchen 2010-04-30 16:57:47 EDT
I bet I had a "null VPN secret" as described in bug 532084.  After deleting the entry manually in seahorse, I was able to re-enter the password in the connection editor without a crash.  That still leaves the question of how the null secret got in my keyring.
Comment 3 Dan Williams 2010-06-28 18:16:12 EDT
Yeah, though there was one location that wasn't checking for a NULL secret.

Upstream fix:

6893b3d0dde4e05ee47b60fcba8e2710346722a4 (master)
ab31b835558935192d034b96c97eedd803edc798 (0.8.1)
Comment 4 Fedora Update System 2010-07-22 12:36:36 EDT
NetworkManager-0.8.1-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-1.fc13
Comment 5 Fedora Update System 2010-07-22 12:39:58 EDT
NetworkManager-0.8.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-1.fc12
Comment 6 Fedora Update System 2010-07-22 22:43:57 EDT
NetworkManager-0.8.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-1.fc13
Comment 7 Fedora Update System 2010-07-26 22:34:25 EDT
NetworkManager-0.8.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-08-17 13:11:03 EDT
NetworkManager-0.8.1-4.git20100817.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-4.git20100817.fc12
Comment 9 Fedora Update System 2010-08-31 21:43:34 EDT
NetworkManager-0.8.1-6.git20100831.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.1-6.git20100831.fc12
Comment 10 Fedora Update System 2010-09-26 00:35:11 EDT
NetworkManager-0.8.1-6.git20100831.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.