Bug 587793 - X crash after gnome shell is started
Summary: X crash after gnome shell is started
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-30 21:21 UTC by Vaclav "sHINOBI" Misek
Modified: 2010-05-01 13:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-01 13:37:14 UTC
Type: ---


Attachments (Terms of Use)
log from /var/log/gdm/ (89.40 KB, application/x-troff-man)
2010-04-30 21:21 UTC, Vaclav "sHINOBI" Misek
no flags Details
environment settings (3.27 KB, text/plain)
2010-05-01 11:06 UTC, Vaclav "sHINOBI" Misek
no flags Details
glxinfo output (14.55 KB, text/plain)
2010-05-01 11:07 UTC, Vaclav "sHINOBI" Misek
no flags Details

Description Vaclav "sHINOBI" Misek 2010-04-30 21:21:34 UTC
Created attachment 410601 [details]
log from /var/log/gdm/

Description of problem:
After gnome-shell is started with export CLUTTER_VBLANK=none (it doesn't work without this env setting), there appears a gnome-shell desktop for the second and then the X crashes and returns to the gdm login screen. There is Xorg: radeon_texture.c:1023: radeon_get_tex_image: Assertion `image->base.Data' failed. error in log.

Version-Release number of selected component (if applicable):
mesa-drivers-7.8.1-5.fc13.x86_64

Steps to Reproduce:
1. export CLUTTER_VBLANK=none
2. gnome-shell --replace

  
Actual results:
short gnome-shell environment and crash

Comment 1 Owen Taylor 2010-05-01 10:31:11 UTC
The fact that X crashed within a Mesa source file - radeon_texture.c - implies that you are running with "indirect rendering" - where the X server is doing the GL rendering instead of the client. The crash in Mutter you are seeing without CLUTTER_VBLANK=none (reported in 577512) also looks like indirect rendering - as far as I can decode it, it looks like gnome-shell was sending a detailed rendering stream over the GLX protocol.

This is unexpected... we supposedly should be using direct rendering almost always.

Can you describe in detail what steps you are taking to launch gnome-shell in the described experiments? (Alon the lines of "Log in to GNOME with the standard Metacity desktop. Open a terminal. Run 'CLUTTER_VBLANK=none ./gnome-shell'")

Can you attach, as attachments:

 a) The output of 'glxinfo' (from the terminal you are using to start gnome-shell)
 b) The output of 'env'  (from the terminal you are using to start gnome-shell)

Thanks!

Comment 2 Vaclav "sHINOBI" Misek 2010-05-01 10:56:45 UTC
OK, I'm really just trying it opening terminal and running above mentioned commands. No special settings and it's run from standard metacity desktop.

Comment 3 Vaclav "sHINOBI" Misek 2010-05-01 11:06:33 UTC
Created attachment 410661 [details]
environment settings

Comment 4 Vaclav "sHINOBI" Misek 2010-05-01 11:07:08 UTC
Created attachment 410662 [details]
glxinfo output

Comment 5 Owen Taylor 2010-05-01 11:18:53 UTC
Don't see anything interesting in the environment. From glxinfo:

direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

Can you try setting LIBGL_DEBUG=verbose and see if you get useful additional information?

Comment 6 Vaclav "sHINOBI" Misek 2010-05-01 13:37:14 UTC
Errm. I checked GL libraries loaded by glxinfo and it seems nvidia proprietary driver libraries were messing with the system. I wiped them out and it seems to be OK. I'm sorry for the noise :-(.


Note You need to log in before you can comment on or make changes to this bug.