Bug 587816 - Regression kernel 2.6.33.2-41 -> 2.6.33.2-57 / i915 60 interrupts/s
Regression kernel 2.6.33.2-41 -> 2.6.33.2-57 / i915 60 interrupts/s
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-30 19:20 EDT by Markus B.
Modified: 2010-12-01 12:29 EST (History)
7 users (show)

See Also:
Fixed In Version: 14
Doc Type: Bug Fix
Doc Text:
The problem disappeared in Fedora 14.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-01 12:29:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
inteltool -a (156.72 KB, text/plain)
2010-06-01 08:40 EDT, Markus B.
no flags Details

  None (edit)
Description Markus B. 2010-04-30 19:20:13 EDT
Description of problem:
Since kernel 2.6.33.2-57 powertop shows about 60 i915 interrupts per second on an idle machine. Kernel 2.6.33.2-41 was fine.

==================
kernel 2.6.33.2-57
==================
PowerTOP 1.11   (C) 2007, 2008 Intel Corporation 

Collecting data for 10 seconds 


Cn                Avg residency
C0 (cpu running)        ( 2.2%)
C0                0.0ms ( 0.0%)
C1 halt           0.0ms ( 0.0%)
C2                0.2ms ( 0.1%)
C3                7.8ms (97.7%)
P-states (frequencies)
  2.01 Ghz     2.0%
  2.00 Ghz     0.0%
  1.60 Ghz     0.4%
  1200 Mhz     0.2%
   800 Mhz    97.3%
Wakeups-from-idle per second : 129.3    interval: 10.0s
no ACPI power usage estimate available
Top causes for wakeups:
  32.0% ( 64.9)     <kernel core> : hrtimer_start_range_ns (tick_sched_timer) 
  29.4% ( 59.7)       <interrupt> : i915 
  12.0% ( 24.4)      <kernel IPI> : Rescheduling interrupts 
   5.4% ( 11.0)       <interrupt> : uhci_hcd:usb6, ath 
   4.3% (  8.7)     <kernel core> : hrtimer_start (tick_sched_timer) 
   3.6% (  7.3)       <interrupt> : ahci 
   2.5% (  5.0)       <interrupt> : ata_piix 
   2.1% (  4.2)       <interrupt> : acpi 
   2.0% (  4.0)     <kernel core> : __mod_timer (rh_timer_func) 

==================
kernel 2.6.33.2-41
==================
PowerTOP 1.11   (C) 2007, 2008 Intel Corporation 

Sammle Daten für 10 Sekunden 


Cn                 Verweildauer
C0 (Prozessor läuft)    ( 2,2%)
C0                0,0ms ( 0,0%)
C1 halt           0,0ms ( 0,0%)
C2                0,2ms ( 0,1%)
C3               14,1ms (97,7%)
P-States (Frequenzen)
  2,01 GHz     4,7%
  2,00 GHz     0,0%
  1,60 GHz     1,0%
  1200 MHz     0,0%
   800 MHz    94,3%
Aufwachen pro Sekunde : 73,0    Intervall: 10,0s
Keine ACPI Stromverbrauch-Schätzung verfügbar
Häufigste Ursachen für das Aufwachen:
  46,2% ( 72,0)     <Kernel Kern> : hrtimer_start_range_ns (tick_sched_timer) 
  15,4% ( 24,0)      <Kernel IPI> : Rescheduling interrupts 
  10,3% ( 16,0)       <interrupt> : uhci_hcd:usb6, ath 
   8,3% ( 12,9)     <Kernel Kern> : hrtimer_start (tick_sched_timer) 
   3,2% (  5,0)       <interrupt> : ata_piix
Comment 1 Markus B. 2010-05-04 16:18:34 EDT
The same problem in kernel 2.6.33.3-72.fc13.x86_64
Comment 2 Attilio 2010-05-17 05:45:28 EDT
I'm experiencing the same behavior, AFAIK it's due to a problem in the intel graphics driver, see: http://www.lesswatts.org/projects/powertop/known.php#intelgfx
Comment 3 Markus B. 2010-05-19 17:35:01 EDT
@Attilio: I thought this bug was fixed a long time ago.

The same problem in kernel 2.6.33.4-95.fc13.x86_64.
Comment 4 Markus B. 2010-06-01 08:39:36 EDT
The same problem in kernel 2.6.33.5-112.fc13.x86_64.

# lspci -vvv
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
	Subsystem: Acer Incorporated [ALI] Device 011f
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Region 0: Memory at fc100000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [d0] Power Management version 3
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
		Bridge: PM- B3+

I've attached the output of
# inteltool -a

I can provide more infos on request.

The other two boxes I own (945 chipset) don't snow 60 interrupts/s.
Comment 5 Markus B. 2010-06-01 08:40:26 EDT
Created attachment 418622 [details]
inteltool -a
Comment 6 Markus B. 2010-12-01 12:29:06 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The problem disappeared in Fedora 14.

Note You need to log in before you can comment on or make changes to this bug.