Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 587829 - default partitioning is busted
default partitioning is busted
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-30 21:03 EDT by jmccann
Modified: 2015-01-14 18:25 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 07:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
metherid: fedora_requires_release_note?


Attachments (Terms of Use)

  None (edit)
Description jmccann 2010-04-30 21:03:38 EDT
A fresh install of F13 nightly from last night results in:
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/vg_quoll-lv_root
                       50G  2.6G   47G   6% /
tmpfs                 991M  384K  990M   1% /dev/shm
/dev/sda1             485M   28M  432M   6% /boot
/dev/mapper/vg_quoll-lv_home
                       20G  4.5G   15G  24% /home

Surely this isn't what we want.  I don't see how creating a partition scheme like this helps our users.
Comment 1 Chris Lumens 2010-05-01 20:47:38 EDT
The best time to discuss this was way back in October when there was plenty of time to test possible algorithms before the release was imminent:

https://www.redhat.com/archives/anaconda-devel-list/2009-October/msg00517.html

Anyway, there has to be a cutoff at some point where we switch from not making a /home partition to where we do.  I think wherever we put this cutoff, the potential exists for a stupidly sized /home.  You just so happen to be installing on a drive sized just right to fit into the current stupid /home size range.  What are common drive sizes these days, and how many people are going to fall into that?  What's your better suggestion for what to do here?
Comment 2 Colin Walters 2010-05-04 09:21:16 EDT
The fundamental problem I see is that the OS root (/) can demand large amounts of space periodically (mainly yum upgrades), but the entire point of the operating system is to hold user data (/home), so we need to maximize that.

I guess I don't understand what we're gaining from a separate /home, given that preupgrade acts as a nondestructive upgrade, and even without preupgrade, it just shouldn't be hard to blow away everything except /home.

I guess it's hard to change this now for F-13, but possibly at least bump the heuristic so that 64GB lies within the "one /" case?

Post-install, how hard is this to change?  I guess you'd need to boot with a live USB, but it should be possible to resize the ext4 filesystems, right?
Comment 3 jmccann 2010-05-04 10:55:53 EDT
For the record, I have an 80GB Intel SSD.

It seems that the 50GB value was selected in order to fit an Everything install.  It seems pretty weird to design the filesystem layout around this pathological case.

In the old, old, days sysadmins used to use home partitions in order to share data across systems and OSs.  That really isn't the case here for a standalone Fedora install.  It has been suggested that a separate /home is useful for preserving data across updates.  In fact I used to do this in a professional sysadmin capacity in a previous job.  However, in my experience it was always a tremendous pain to balance the variable size of / and /home across OS updates.

There just isn't a very good way to predict future use in general and no algorithm is going to be able to help you.  Chances are you will size the system too small or too large.  In cases where the monetary cost of the selection is low then naturally you will tend to pick the safest and largest value - but with the largest potential waste.  This is the case here because the cost of the safety isn't being borne by the OS vendor.  However, for the user who spent hundreds or thousands of dollars on a computer the cost/benefit is inverted.  There is no benefit to me to have a huge chunk of my valuable SSD wasted to support an Everything install that nobody should ever perform.  Also see the difficulty encountered with the size of /boot.

It is probably better to use a "pay as you go" system instead of hard, fixed partitions.

As for the discussion on anaconda list, I'm not on that list and I don't expect many others are either.  I guess I'd suggest that we should try to all work together to make sure we are building the kind of OS we want.  Maybe changes that impact the desktop user experience should be discussed on the desktop mailing list or something.  Hopefully that will help us avoid unexpected clashes of expectations.

Also, it seems particularly ill advised to put this into F13 since we don't yet have partition resizing tools in the Disk Utility.
Comment 4 David Lehman 2010-05-04 12:31:54 EDT
First of all, "busted" just might be an opinion as opposed to a fact.

There were plenty of people who felt that putting /home on the same device as the root filesystem is/was broken. The fact is that having a separate /home does ease reinstall. Preupgrade is not the only way users can/should update the OS.

These are logical volumes, not disk partitions (how much difference that makes is debatable). More to the point, users who have strong opinions have the opportunity to modify the default layout during installation or simply create whatever custom layout they think is best. There is also the option of resizing logical volumes and their containing filesystems post-install.
Comment 5 Hans de Goede 2010-05-10 07:38:09 EDT
Closing this, the proper place to discuss better defaults for this for F-14 is the anaconda mailing list, not bugzilla.

Note You need to log in before you can comment on or make changes to this bug.