Bug 587879 - Inconsistent terminology in anaconda storage devices dialog window
Inconsistent terminology in anaconda storage devices dialog window
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-01 06:24 EDT by Bruce Jerrick
Modified: 2010-05-05 09:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-14.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 09:51:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2010-05-01 06:24:15 EDT
Description of problem:
In the storage devices dialog window that is shown early in the anaconda
installation procedure, the language used to denote the two categories of
storage devices is inconsistent, and hence unclear when encountered for
the first time.

Version-Release number of selected component (if applicable):
anaconda-13.37.2-1.fc13

How reproducible:
100%

Steps to Reproduce:
1. Perform OS installation.
2. Observe storage devices dialog window ("Below are the storage devices
   you've selected to be part of this installation.").
  
Actual results:
The message at the top uses the terms "data drives" and "system drives",
yet the tables below it are headed "Data Storage Devices" and "Install
Target Devices".

Expected results:
A better correspondence between what is described and what is actually
shown.

Additional info:

Suggested fix:

  Change "data drives" to "data devices".
  More importantly, change "system drives" to "install target devices" (i.e.,
  match the table header verbatim).

  Also, if it's possible to be brief, it would be nice to have some
  explanation of just what a "data storage device" might be used for
  (data storage, I suppose).  An opportune place would be after the
  parenthetical "these will not be formatted, only mounted".

(BTW, is there a way to specify the "Install Target Devices" in a kickstart
file, so this new dialog window isn't shown; and if there is, is it
documented?)
Comment 1 Chris Lumens 2010-05-01 20:48:56 EDT
It's too late to change this in F13 due to the string freeze.  It'll have to wait for F14.

And yes - all the new screens can be controlled via kickstart.  The screen you're referring to is really just a UI on top of the clearpart command.

Note You need to log in before you can comment on or make changes to this bug.