Bug 587883 - boolstuff 0.1.13 is out
boolstuff 0.1.13 is out
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: boolstuff (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-01 06:46 EDT by Patrice Dumas
Modified: 2010-05-10 08:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-01 15:43:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2010-05-01 06:46:48 EDT
Description of problem:

I haven't tested is, but the previous version 0.1.12 worked fine, and didn't need the following patches anymore:

boolstuff-0.1.11-gcc43.patch
boolstuff-0.1.11-gcc44-fixes.diff



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Conrad Meyer 2010-05-01 15:43:21 EDT
Ok, I've removed those patches and it seems to build fine locally.

The package has been updated in rawhide ( http://koji.fedoraproject.org/koji/taskinfo?taskID=2154177 ) and F-13 ( http://koji.fedoraproject.org/koji/taskinfo?taskID=2154192 ) and F-12 ( http://koji.fedoraproject.org/koji/taskinfo?taskID=2154195 ).
Comment 2 Patrice Dumas 2010-05-01 16:48:02 EDT
Have you checked that the API and ABI didn't changed for the older releases? I vaguely remember at least a change in API.
Comment 3 Conrad Meyer 2010-05-01 16:52:57 EDT
$ repoquery --whatrequires boolstuff
boolstuff-devel-0:0.1.11-8.fc12.i686
booldnf-0:0.1.11-8.fc12.x86_64
boolstuff-devel-0:0.1.11-8.fc12.x86_64

Those are all RPMs from the boolstuff SRPM.
Comment 4 Conrad Meyer 2010-05-01 16:53:44 EDT
I am happy to not push the bump to F-12, but it should go to F-13, IMO.
Comment 5 Patrice Dumas 2010-05-01 17:11:15 EDT
(In reply to comment #3)
> $ repoquery --whatrequires boolstuff
> boolstuff-devel-0:0.1.11-8.fc12.i686
> booldnf-0:0.1.11-8.fc12.x86_64
> boolstuff-devel-0:0.1.11-8.fc12.x86_64
> 
> Those are all RPMs from the boolstuff SRPM.    

you should better do something along
repoquery --archlist=src --whatrequires boolstuff-devel

or
repoquery --whatrequires libboolstuff-0.1.so.0

At least halevt requires boolstuff-devel. I guess it is the only dependency.
Comment 6 Patrice Dumas 2010-05-01 17:14:03 EDT
(In reply to comment #4)
> I am happy to not push the bump to F-12, but it should go to F-13, IMO.    

I tend to disagree, changing API/ABI after the branching seems wrong to me. But you are the maintainer, it is your choice.
Comment 7 Conrad Meyer 2010-05-01 18:34:51 EDT
F-13 hasn't been released yet; I don't see the harm in upgrading if it doesn't break halevt (which doesn't exist in F-12).
Comment 8 Patrice Dumas 2010-05-01 18:48:34 EDT
halevt indeed exists in F-12. Or there is something weird going on. The halevt version in fedora is quite old, though. Newer version requires indeed boolstuff 0.1.12 at least because of the API change I talked about.

In fact this could even be a reason for updating in F-13, such that it is possible to rebuild newer halevt versions.
Comment 9 Conrad Meyer 2010-05-01 19:07:19 EDT
Er, sorry, I misunderstood. halevt doesn't appear to depend on boolstuff in F-12.
Comment 10 Patrice Dumas 2010-05-01 19:18:13 EDT
(In reply to comment #9)
> Er, sorry, I misunderstood. halevt doesn't appear to depend on boolstuff in
> F-12.    

That would be quite strange. Are you sure it doesn't depend on boolstuff soname, which should be like libboolstuff-0.1.so.0?
Comment 11 Conrad Meyer 2010-05-01 23:22:24 EDT
The command:

> repoquery --whatrequires libboolstuff-0.1.so.0

wasn't giving me anything earlier; however:

$ repoquery -qR halevt

reports that it does, indeed, require libboolstuff-0.1.so.0()(64bit)
Comment 12 Conrad Meyer 2010-05-09 22:13:51 EDT
@Patrice: Shall we get a buildroot override and bump halevt in F-13 then?
Comment 13 Patrice Dumas 2010-05-10 08:21:21 EDT
That would certainly be good. But maybe you could send a mail to the current halevt owner (or to the generic fedora halevt-owner mail alias) before processing.

Note You need to log in before you can comment on or make changes to this bug.