Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 587900 - cannot import wx; symbol not defined in .so file
cannot import wx; symbol not defined in .so file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wxPython (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-01 09:47 EDT by pankaj pandey
Modified: 2010-05-15 16:40 EDT (History)
2 users (show)

See Also:
Fixed In Version: wxPython-2.8.10.1-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-15 16:40:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pankaj pandey 2010-05-01 09:47:15 EDT
Description of problem:
wxpython is unusable in fedora, it cannot be imported into python and gives an error.

Version-Release number of selected component (if applicable):
wxPython-2.8.10.1-2.fc13.x86_64

Steps to Reproduce:
1. import wx from a python shell
  
Actual results:
$ python
Python 2.6.4 (r264:75706, Apr  1 2010, 02:55:51) 
[GCC 4.4.3 20100226 (Red Hat 4.4.3-8)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import wx
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/__init__.py", line 45, in <module>
    from wx._core import *
  File "/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 14770, in <module>
    from _misc import *
  File "/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_misc.py", line 4, in <module>
    import _misc_
ImportError: /usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_misc_.so: symbol _ZN7wxSound6CreateEiPKh, version WXU_2.8 not defined in file libwx_gtk2u_adv-2.8.so.0 with link time reference
>>> 

Expected results:
python should import correctly w/o any error messages
Comment 1 Dan Horák 2010-05-03 04:03:06 EDT
It's because new wxGTK 2.8.11 is in updates-testing and updates-testing are enabled by default in F-13. I will rebuild wxPython ASAP.
Comment 2 Fedora Update System 2010-05-03 05:28:10 EDT
wxPython-2.8.10.1-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/wxPython-2.8.10.1-3.fc13
Comment 3 Fedora Update System 2010-05-04 02:19:58 EDT
wxPython-2.8.10.1-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wxPython'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/wxPython-2.8.10.1-3.fc13
Comment 4 Fedora Update System 2010-05-15 16:40:01 EDT
wxPython-2.8.10.1-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.