Bug 587909 - Floppy Disk Emulation causes install hang/floppy driver load hang
Floppy Disk Emulation causes install hang/floppy driver load hang
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Prarit Bhargava
Red Hat Kernel QE team
:
Depends On:
Blocks: 846704
  Show dependency treegraph
 
Reported: 2010-05-01 10:22 EDT by Keith Wilkinson
Modified: 2013-11-12 08:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A BIOS emulated floppy disk might cause ther installation or kernel boot process to hang. To avoid this, disable emulated floppy disk support in the BIOS.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 08:55:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Wilkinson 2010-05-01 10:22:07 EDT
Description of problem:
"What sort of storage device" install screen freeze with RS780 / SB700 chipset.
Fedora 12 already installed on different partitions. 

Version-Release number of selected component (if applicable):
20100414

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Install cannot proceed

Expected results:
Install

Additional info:
Comment 2 RHEL Product and Program Management 2010-05-01 11:17:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Chris Lumens 2010-05-01 20:39:07 EDT
Can you switch VTs (ctrl-alt-f2) at all or is the machine totally unresponsive?
Comment 4 Keith Wilkinson 2010-05-02 02:22:26 EDT
> Can you switch VTs (ctrl-alt-f2)

Yes.  It's just the "storage device" screen that locks up after I click "Next". 

The AMD 780 chipset was the most popular about a year ago, and is supported by RHEL5.5 

The AMD 785 chipset is currently the most popular, and the AMD 880 chipset will be out soon. 

I would think that encouraging people to do RHCE (so that potential RH customers can't say that qualified RHEL support people are hard to find) would benefit RH. 
Not supporting the most popular chipsets does not encourage people to study for RHCE or help Red Hat.
Comment 5 Chris Lumens 2010-05-02 22:45:29 EDT
> > Can you switch VTs (ctrl-alt-f2)
> 
> Yes.  It's just the "storage device" screen that locks up after I click "Next". 

Can you therefore attach /tmp/syslog, /tmp/anaconda.log, and /tmp/storage.log to this bug report so we can have some good data to debug with?  Thanks.
Comment 6 Keith Wilkinson 2010-05-03 13:59:45 EDT
Chris, many thanks for the RFI -- it helped me find a work-around, as follows:

The end of syslog showed repeated fd error messages, even though an fd was not connected. When I looked at the BIOS, the fd had not been disabled. Disabling fd in the BIOS fixed the lockup. I would not have expected such a trivial BIOS setting error to have caused an installation-time freeze with no displayed error message -- it wouldn't have prevented a Windows install. Please consider this as an unfixed bug! 
This (FD not installed, but FD not disabled in the BIOS) may well be the reason that Fedora and other versions of RHEL display a message like "can't reset ATA" and pause for a few seconds during bootup (not yet confirmed). If this is the case, then a more intelligent error message ("No ATA FD? Disable FD in BIOS!") would help. 
And thanks again for the pointer, I could install RHEL6Beta successfully.
Comment 7 Chris Lumens 2010-05-03 15:58:23 EDT
There's already a kernel bug tracking this floppy thing somewhere.  Reassigning.
Comment 8 Keith Wilkinson 2010-05-04 09:49:31 EDT
I'd suspect that bugs 493319 and 248737 are related.  Few people would guess that a long freeze (like in Fedora 11) or a message like "ATA soft reset failed" is really due to having no IDE FD attached and not disabling FD in the BIOS ;-)
Comment 9 Prarit Bhargava 2010-05-18 10:57:53 EDT
Keith,

Can you attach either

a) a copy of sosreport from your system, or
b) a copy of lspci and dmidecode, as well as the vendor name and model of your system?

(sosreport is preferred)

Thanks,

P.
Comment 10 Keith Wilkinson 2010-05-18 11:22:10 EDT
The motherboard is the Gigabyte GA-MA78GPM-DS2H (same as the GA-MA78GM-DS2H but with sideport video memory) and this was the most popular AMD motherboard here in Japan about a year ago. 790- and more recent 785-chipset motherboards are currently the most popular AMD motherboards. The issue that was found and resolved above was "FD (floppy) enabled in BIOS but FD not in fact connected". The "ATA soft reset failed" message also mentioned above is another issue, it is evident in previous RHEL and Fedora releases (other people have reported it), 
and doesn't appear to affect installation or operation. The FD issue is resolved.
Comment 11 Keith Wilkinson 2010-05-18 11:24:19 EDT
> The FD issue is resolved. 

This should read "the obvious workaround is to disable FD in the BIOS, but such a small issue should not cause installation to fail".
Comment 12 Keith Wilkinson 2010-05-19 00:03:40 EDT
If I can find time, I will try to install the RHEL 6 Beta on the 
Gigabyte MA785GM-US2H and MSI 890GXM-G65 motherboards.  

FYI, the current popularity ranking of the most popular AMD motherboards is:
#3 ASRock M3A785GMH/128M 785G+SB710 DDR3 MicroATX 
#4 ASUS M4A89GTD PRO/USB3 890GX+SB850+USB3 DDR3 ATX 
#5 ASUS M4A785D-M PRO 785G+SB710 DDR2 MicroATX 
#6 MSI 785GM-P45 785G+SB710 DDR3 MicroATX 
#9 ASUS Crosshair IV Formula 890FX+SB850+USB3 DDR3 ATX 
#13 MSI 890GXM-G65 890GX+SB850+USB3 DDR3 MicroATX 
#15= ASUS M4A88TD-V EVO/USB3 880G+SB850+USB3 DDR3 ATX 
(Note: seems 880 chipset is not yet supported by latest kernel) 
#17 Gigabyte GA-890FXA-UD5 Rev.2.0 890FX+SB850+USB3 DDR3 ATX 
#19= ASUS M4A87TD/USB3 870+SB850+USB3 DDR3 ATX
Comment 13 Keith Wilkinson 2010-06-09 00:31:11 EDT
I was able to install the RHEL 6 Beta on a Gigabyte 880GMA-UD2H motherboard. 
Although the video type is not recognized, it works perfectly. HD 5000 series video is apparently -- even now -- not yet fully supported in the latest LINUX kernels, but everything works, so I'd rate that as superb!
Comment 14 RHEL Product and Program Management 2010-07-15 10:24:36 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 18 Prarit Bhargava 2010-08-11 15:08:11 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
Release Note ASAP
Comment 20 Ryan Lerch 2010-08-31 20:23:33 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1,3 @@
-Release Note ASAP+It has been noted that BIOS emulated floppy disk may cause a long
+hang in the installation or kernel boot.  To avoid this hang, disable emulated
+floppy disk support in the BIOS.
Comment 23 Ryan Lerch 2010-10-18 22:11:44 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,3 +1 @@
-It has been noted that BIOS emulated floppy disk may cause a long
+A BIOS emulated floppy disk might cause ther installation or kernel boot process to hang. To avoid this, disable emulated floppy disk support in the BIOS.-hang in the installation or kernel boot.  To avoid this hang, disable emulated
-floppy disk support in the BIOS.
Comment 24 RHEL Product and Program Management 2011-10-07 11:01:15 EDT
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 26 Prarit Bhargava 2013-11-12 08:55:16 EST
This was only open for release notes.

P.

Note You need to log in before you can comment on or make changes to this bug.