Bug 587919 - Upgrade fails with fs type ntfs-3g in fstab
Summary: Upgrade fails with fs type ntfs-3g in fstab
Status: CLOSED DUPLICATE of bug 577260
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-01 15:02 UTC by Julian Weißgerber
Modified: 2010-05-02 00:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-02 00:40:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda log (253.20 KB, text/plain)
2010-05-01 16:00 UTC, Julian Weißgerber
no flags Details

Description Julian Weißgerber 2010-05-01 15:02:12 UTC
Description of problem:
If a line in fstab has the filesystem type set to ntfs-3g instead of just ntfs, anaconda halts due this exception when an upgrade is attempted:

Exception: fstab entry UUID=36D4BFBDD4BF7DA5 is malformed: scanned format (ntfs) differs from fstab format (ntfs-3g)

Version-Release number of selected component (if applicable):
anaconda 13.39

How reproducible:
Attempt to upgrade a Fedora 12 installation to Fedora 13 (I used preupgrade) while a ntfs volume is contained in /etc/fstab with fs type set to ntfs-3g.

Steps to Reproduce:
1. Change fs type of a ntfs volume in /etc/fstab from ntfs to ntfs-3g in the existing installation
2. Attempt to upgrade
  
Actual results:
The installer halts.

Expected results:
Installer should start upgrading the system (as it does when the mentioned line in fstab is set to ntfs instead of ntfs-3g).

Additional info:

Comment 1 Julian Weißgerber 2010-05-01 16:00:44 UTC
Created attachment 410696 [details]
anaconda log

Comment 2 Chris Lumens 2010-05-02 00:40:57 UTC

*** This bug has been marked as a duplicate of bug 577260 ***


Note You need to log in before you can comment on or make changes to this bug.