Bug 587923 - RFE: tar doesn't have a way to display saved xattrs
RFE: tar doesn't have a way to display saved xattrs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tar (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Pavel Raiskup
qe-baseos-daemons
: FutureFeature
: 714990 (view as bug list)
Depends On:
Blocks: 1159824
  Show dependency treegraph
 
Reported: 2010-05-01 11:29 EDT by Ted X Toth
Modified: 2016-07-25 04:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-25 04:04:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted X Toth 2010-05-01 11:29:46 EDT
Description of problem:
When tar file is created with --xattrs subsequent `tar tv` doesn't show the SELinux context and ACLs save with the file.

Version-Release number of selected component (if applicable):
tar-1.22.13

How reproducible:
very


Steps to Reproduce:
1. tar some files with --xattrs option then run tar tvf on the tar file and see
that the SELinux context and ACLs aren't displayed.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 RHEL Product and Program Management 2010-05-01 13:13:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Ondrej Vasik 2010-05-03 03:59:19 EDT
Thanks for report. However - I think showing those xattrs/acls/selinux contexts (which are not shown at the moment) by default with -tv option would cause much more confusion than not showing them at all. Actually - upstream tar doesn't store them at all - so first step about this xattrs/acl/selinux patch is to get it accepted by upstream. Then (maybe) "--xattrs -tv" could show those extended attributes/acls/selinux contexts of the files in the archive.
I'm marking that feature request as FutureFeature and will consider it later - definitely not by default...
Comment 5 Suzanne Yeghiayan 2011-01-06 17:19:52 EST
This request was evaluated by Red Hat Product Management for 
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated 
in the current release, Red Hat is unfortunately unable to  
address this request at this time.  This request has been 
proposed for the next release of Red Hat Enterprise Linux.
If you would like it considered as an exception in the 
current release, please ask your support representative.
Comment 6 Ondrej Vasik 2011-06-21 16:20:56 EDT
*** Bug 714990 has been marked as a duplicate of this bug. ***
Comment 7 RHEL Product and Program Management 2011-07-05 19:43:50 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 14 Pavel Raiskup 2012-09-27 03:23:27 EDT
Just to refresh status of this bug.  I proposed new xattrs patch to upstream
tar (with no response yet):

  http://lists.gnu.org/archive/html/bug-tar/2012-08/msg00012.html

If you want to try this feature, you may use tar from Fedora Rawhide:

  https://koji.fedoraproject.org/koji/buildinfo?buildID=349824

Note that (1) listing feature is just a concept and it should be ACKed by
upstream first and (2) fedora-rawhide has whole "new" xattr patch including tar
tar's API change - only the listing-related part of patch would be applicable
for RHEL-6.

Thanks,
Pavel
Comment 15 RHEL Product and Program Management 2013-10-13 21:20:49 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 16 Pavel Raiskup 2016-07-25 04:04:27 EDT
It is too late for feature requests in RHEL6 (production phase 2) so I'm
closing.  Feel free to try "tar -tvv --xattrs-include='*'"  on RHEL7.

Note You need to log in before you can comment on or make changes to this bug.