Bug 587927 - evince attempts to use libmimx-ispell.so
evince attempts to use libmimx-ispell.so
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: m17n-db (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-01 11:49 EDT by Bruno Wolff III
Modified: 2010-07-07 13:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: m17n-db-1.5.5-4.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 13:52:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2010-05-01 11:49:09 EDT
Description of problem:
When running evince I get a non-fatal error:
libmimx-ispell.so: cannot open shared object file: No such file or directory

As far as I can tell, nothing provides this in F13.

Version-Release number of selected component (if applicable):
evince-2.30.1-2.fc13.i686

How reproducible:
Seems to be 100%.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marek Kašík 2010-05-06 07:11:17 EDT
Hi Bruno,

could you send me list of m17n packages installed on your system?
Just run "rpm -qa | grep m17n".
Did you compiled evince or some library yourself? (eg. gtk2)

Thanks

Marek
Comment 2 Bruno Wolff III 2010-05-06 07:51:52 EDT
I don't have any hand built libraries.
I have the following m17n stuff installed:
m17n-db-cham-1.5.5-3.fc13.noarch
m17n-db-thai-1.5.5-3.fc13.noarch
m17n-contrib-punjabi-1.1.10-3.fc13.noarch
m17n-db-malayalam-1.5.5-3.fc13.noarch
m17n-db-kazakh-1.5.5-3.fc13.noarch
m17n-contrib-urdu-1.1.10-3.fc13.noarch
m17n-db-lao-1.5.5-3.fc13.noarch
m17n-contrib-1.1.10-3.fc13.noarch
m17n-db-1.5.5-3.fc13.noarch
m17n-db-vietnamese-1.5.5-3.fc13.noarch
uim-m17n-1.5.7-2.fc13.i686
m17n-contrib-chinese-1.1.10-3.fc13.noarch
m17n-db-hebrew-1.5.5-3.fc13.noarch
m17n-contrib-tai-1.1.10-3.fc13.noarch
m17n-db-latin-1.5.5-3.fc13.noarch
m17n-db-datafiles-1.5.5-3.fc13.noarch
m17n-contrib-sindhi-1.1.10-3.fc13.noarch
m17n-db-greek-1.5.5-3.fc13.noarch
m17n-contrib-malayalam-1.1.10-3.fc13.noarch
m17n-contrib-bengali-1.1.10-3.fc13.noarch
scim-m17n-0.2.3-2.fc12.i686
m17n-contrib-esperanto-1.1.10-3.fc13.noarch
m17n-db-assamese-1.5.5-3.fc13.noarch
m17n-db-swedish-1.5.5-3.fc13.noarch
m17n-db-armenian-1.5.5-3.fc13.noarch
m17n-contrib-kannada-1.1.10-3.fc13.noarch
m17n-contrib-vietnamese-1.1.10-3.fc13.noarch
m17n-db-croatian-1.5.5-3.fc13.noarch
m17n-db-telugu-1.5.5-3.fc13.noarch
m17n-db-gujarati-1.5.5-3.fc13.noarch
m17n-contrib-pashto-1.1.10-3.fc13.noarch
m17n-db-slovak-1.5.5-3.fc13.noarch
m17n-db-russian-1.5.5-3.fc13.noarch
m17n-contrib-nepali-1.1.10-3.fc13.noarch
m17n-db-dhivehi-1.5.5-3.fc13.noarch
m17n-db-serbian-1.5.5-3.fc13.noarch
m17n-db-flt-1.5.5-3.fc13.noarch
m17n-db-bengali-1.5.5-3.fc13.noarch
m17n-contrib-telugu-1.1.10-3.fc13.noarch
m17n-db-punjabi-1.5.5-3.fc13.noarch
m17n-db-tibetan-1.5.5-3.fc13.noarch
m17n-contrib-assamese-1.1.10-3.fc13.noarch
m17n-db-french-1.5.5-3.fc13.noarch
m17n-db-arabic-1.5.5-3.fc13.noarch
m17n-db-myanmar-1.5.5-3.fc13.noarch
m17n-contrib-tamil-1.1.10-3.fc13.noarch
m17n-db-chinese-1.5.5-3.fc13.noarch
m17n-contrib-sinhala-1.1.10-3.fc13.noarch
m17n-db-sinhala-1.5.5-3.fc13.noarch
m17n-db-syriac-1.5.5-3.fc13.noarch
m17n-lib-flt-1.5.5-2.fc13.i686
m17n-db-farsi-1.5.5-3.fc13.noarch
m17n-db-danish-1.5.5-3.fc13.noarch
m17n-db-sanskrit-1.5.5-3.fc13.noarch
m17n-contrib-gujarati-1.1.10-3.fc13.noarch
m17n-db-japanese-1.5.5-3.fc13.noarch
m17n-contrib-hindi-1.1.10-3.fc13.noarch
m17n-contrib-kashmiri-1.1.10-3.fc13.noarch
m17n-db-common-cjk-1.5.5-3.fc13.noarch
m17n-db-uyghur-1.5.5-3.fc13.noarch
m17n-db-generic-1.5.5-3.fc13.noarch
m17n-contrib-czech-1.1.10-3.fc13.noarch
m17n-lib-anthy-1.5.5-2.fc13.i686
m17n-db-oriya-1.5.5-3.fc13.noarch
m17n-contrib-russian-1.1.10-3.fc13.noarch
m17n-db-gregorian-1.5.5-3.fc13.noarch
m17n-db-devel-1.5.5-3.fc13.noarch
m17n-db-tamil-1.5.5-3.fc13.noarch
m17n-db-kannada-1.5.5-3.fc13.noarch
m17n-contrib-maithili-1.1.10-3.fc13.noarch
m17n-contrib-marathi-1.1.10-3.fc13.noarch
m17n-db-korean-1.5.5-3.fc13.noarch
m17n-db-khmer-1.5.5-3.fc13.noarch
m17n-lib-1.5.5-2.fc13.i686
m17n-lib-devel-1.5.5-2.fc13.i686
m17n-db-hindi-1.5.5-3.fc13.noarch
m17n-contrib-oriya-1.1.10-3.fc13.noarch
m17n-db-amharic-1.5.5-3.fc13.noarch
Comment 3 Marek Kašík 2010-05-06 11:46:26 EDT
Does it show up with fully updated system? Do you see it with another application (gedit, eog, ...)?

Marek
Comment 4 Bruno Wolff III 2010-05-06 12:13:04 EDT
My system is pretty fully updated. I typically get updates from the kernel mirrors within a few hours of new branch, updates or updates-testing repos. I also pull some stuff from koji directly (typically graphics and boot related stuff).
I just tested gedit and eog. gedit shows the problem but eog doesn't.
Comment 5 Marek Kašík 2010-05-07 06:29:25 EDT
I can reproduce the problem now. It is enough to install and activate uim input method and run evince, gedit or gtk-demo. It also shows up with scim input method but only with gedit.
It is probably caused by subpackage m17n-db-generic. In /usr/share/m17n/ispell.mim is written that it uses libmimx-ispell.so to communicate with ISPELL program. But libmimx-ispell.so is not compiled in m17n-lib (it is if-ed in its spec file).

I'm reassigning this to m17n-db.

Regards

Marek
Comment 6 Jens Petersen 2010-05-07 08:45:17 EDT
Hmm, maybe we should just remove ispell.mim for now?
I don't think it is very useful.

@Bruno, are you using scim or uim?  Wonder if it happens with ibus.
Comment 7 Bruno Wolff III 2010-05-07 09:25:40 EDT
No. (At least I tried to disable all of the special input stuff.) I just have it installed. I like to do a kitchen sink type install on at least one of my machines, so that I can find install issues. I have a lot of stuff installed that I don't really use.
Comment 8 Jens Petersen 2010-05-20 01:28:33 EDT
What does "imsettings-info" output for you?
Comment 9 Jens Petersen 2010-05-20 01:36:54 EDT
You can still reproduce?
Comment 10 Bruno Wolff III 2010-05-20 01:49:05 EDT
libmimx-ispell.so: cannot open shared object file: No such file or directory
bash-4.1$ imsettings-info
No Input Method running. please specify Input Method name explicitly if necessary.
bash-4.1$ 

Yes, it is still happening.
Comment 11 Jens Petersen 2010-05-21 05:55:57 EDT
Could you try removing m17n-db-generic, scim-m17n, and uim-m17n in turn to see which causes the problem?
Comment 12 Bruno Wolff III 2010-05-21 11:37:15 EDT
On the first test when I removed m17n-db-generic I didn't get the previous message, but did get some others:
Error: stub IM actualization failed
libuim: [fatal] an unhandled error raised from Scheme interpreter
libuim: All functionality has been disabled to save user application data.
libuim: [fatal] an unhandled error raised from Scheme interpreter
libuim: [fatal] All functionality has been disabled to save user application data.

(evince:14540): Gtk-WARNING **: Loading IM context type 'uim' failed

(evince:14540): Gtk-WARNING **: Loading IM context type 'uim' failed
Comment 13 Bruno Wolff III 2010-05-21 11:47:18 EDT
Removing just scim-m17n (and scim dependencies) had no effect on the error message.
Comment 14 Bruno Wolff III 2010-05-21 11:53:03 EDT
Removing just uim-m17n got rid of the error message without introducing new ones.
Comment 15 Bruno Wolff III 2010-05-21 11:57:31 EDT
With both m17n-db-generic and uim-m17n removed, I also didn't get any error messages. Is uim-m17n missing a dependency on m17n-db-generic or are the extra messages just an artefact of how evince checks for option libraries?
Comment 16 Jens Petersen 2010-05-23 22:55:55 EDT
Hmm I think uim-m17n may handle missing .mim files less
gracefully than other IMs.  (In F14 we are dropping nearly all
the m17n-db subpackages FWIW so that might help.)
Comment 17 Jens Petersen 2010-05-23 23:02:33 EDT
But I guess we should remove ispell.mim anyway in line with m17n-lib.
Comment 18 Fedora Update System 2010-07-01 06:49:07 EDT
m17n-db-1.5.5-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/m17n-db-1.5.5-4.fc13
Comment 19 Fedora Update System 2010-07-01 14:43:52 EDT
m17n-db-1.5.5-4.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update m17n-db'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/m17n-db-1.5.5-4.fc13
Comment 20 Fedora Update System 2010-07-07 13:52:28 EDT
m17n-db-1.5.5-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.