Bug 58793 - Mime type doesn't work
Mime type doesn't work
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: tux (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ingo Molnar
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-24 14:40 EST by Matthias Saou
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-04 07:59:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2002-01-24 14:40:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020109

Description of problem:
When enabling tux, the mime type of .html files is set to text/plain by default.
They get displayed as-is by the browser.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. service tux start
2. go to http://localhost/index.html
3. get the html listing as plain text
	

Actual Results:  HTTP/1.1 200 OK
Content-Type: text/plain
Connection: Keep-Alive
Date: 
Server: TUX/2.0 (Linux)
Content-Length: 2890
ETag: "2890-dmbpjgnp"
Accept-Ranges: bytes
Last-Modified: Tue, 18 Dec 2001 19:19:59 GMT


Expected Results:  text/html would have been better :-)

Additional info:

Trying the /etc/tux.mime.types file on an older version of tux worked fine.
Comment 1 Michael K. Johnson 2002-03-27 17:24:16 EST
Should be fixed in current rawhide
Comment 2 Brian Brock 2002-04-01 18:15:08 EST
Bug confirmed to exist in tux-2.2.5-1, same results.
Comment 3 Brian Brock 2002-04-03 15:14:19 EST
This bug does not appear with tux-2.2.4-1 and kernel-2.4.9-26beta.53.
Comment 4 Michael K. Johnson 2002-04-04 15:07:07 EST
Please test tux-2.2.5-1 and kernel-2.4.9-26beta.53 -- there are no differences
in tux that would affect this between 2.2.4 and 2.2.5 -- the only difference
is that the tux initscript runs "sysctl -p /etc/sysctl.tux" if /etc/sysctl.tux
exists, and the documentation was modified to account for the change.
Comment 5 Matthias Saou 2002-04-05 11:07:41 EST
Well, a quick test with current rawhide packages still doesn't work :
kernel-2.4.18-0.13
tux-2.2.5-1

Here is my /etc/sysctl.conf :
# Tux configuration
net.tux.virtual_server = 0
net.tux.http_dir_indexing = 1
net.tux.ftp_subdocroot = /ftp/
net.tux.http_subdocroot = /html/
net.tux.logging = 1

I get the source of the default index.html apache page when trying to access the
running Tux httpd server :-(
Comment 6 Michael K. Johnson 2002-04-05 11:44:36 EST
Sorry, Matthias, my last comment was directed at bbrock, not you.
I apologize for not making that clear.
Comment 7 Matthias Saou 2002-04-05 12:06:22 EST
I had guessed so since I don't think I can get my hands on kernel
2.4.9-26beta.53... ;-)
But since an older comment said that things were supposed to be fixed in current
rawhide, I thought I might as well mention that they aren't for me, at least not
anymore.

Could it be something I'm doing wrong? :-/
Comment 8 Brian Brock 2002-04-30 18:47:00 EDT
don't see this with tux-2.2.[45]-1 and kernel-2.4.9-26beta${foo} for values of
${foo} greater than in rawhide that are relatively close to 53.

Note You need to log in before you can comment on or make changes to this bug.