Bug 587995 - Correction: Incorrect path to multipath doc files
Correction: Incorrect path to multipath doc files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-DM_Multipath (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Steven J. Levine
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-01 22:31 EDT by Justin Clift
Modified: 2010-11-11 10:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 10:27:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Clift 2010-05-01 22:31:27 EDT
Description of problem:

In "Chapter 4. The DM-Multipath Configuration File", it gives explicit paths to the example multipath files installed on RHEL x.

However, in the RHEL 6 version of the guide, this is wrong.

Explicit paths mentioned:

  /usr/share/doc/device-mapper-multipath-0.4.7/multipath.conf.defaults
  /usr/share/doc/device-mapper-multipathd-0.4.7/multipath.conf.annotated

The actual paths in the present RHEL 6 beta are:

  /usr/share/doc/device-mapper-multipath-0.4.9/multipath.conf.defaults
  /usr/share/doc/device-mapper-multipath-0.4.9/multipath.conf.annotated

(It's not just the version number, there's an extra "d" in the path too)
Comment 2 RHEL Product and Program Management 2010-05-01 23:22:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Steven J. Levine 2010-09-20 17:48:10 EDT
I have updated the references to these paths in the RHEL 6 working draft of the DM-Multipath document. Thanks for catching this.
Comment 5 Steven J. Levine 2010-10-12 16:34:39 EDT
I am marking this bug as MODIFIED since the changes have been checked in to the SVN repository and posted on the review server.
Comment 7 Michael Doyle 2010-10-14 23:25:30 EDT
Verified in Red_Hat_Enterprise_Linux-DM_Multipath-6-en-US-1-18.

[comment] as version number change consider using 

/usr/share/doc/device-mapper-multipath-<version>/
Comment 8 releng-rhel@redhat.com 2010-11-11 10:27:40 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.