Bug 588051 - NetworkManager isn't able config interface on IPv4 network in offered default TCP/IP scenario
Summary: NetworkManager isn't able config interface on IPv4 network in offered default...
Status: CLOSED DUPLICATE of bug 567978
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-02 12:03 UTC by Frantisek Hanzlik
Modified: 2010-05-03 10:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 10:05:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Frantisek Hanzlik 2010-05-02 12:03:33 UTC
Description of problem:
tried f13-rawhide network (askmethod) install on IPv4 network with DHCP server, when on anaconda "Configure TCP/IP" screen leave preset options (Enable IPv4 support/Enable dynamic configuration and Enable IPv6 support/Automatic neighbor discovery), then NM ends with error:

Network error - There was an error configuring your network interface

Version-Release number of selected component (if applicable):
boot.iso image from 1-May-2010 (anaconda 13.39)

Reproducible always, dumps on fourth screen shows how dhclient obtain right informations from DHCP server, and continue NM dump (approx.):
Activation (eth1) Stage 4 of 5 (IP4 Configure Get) complete.
(eth1): IP6 addrconf timed out or faild
device state change: 7 -> 9 (reaseon 5)
Marking connection 'System eth1' invalid
Activation (eth1) failed.
...

When not selecting IPv6, iface IPv4 configuration work OK and installation continue normally. But I think most people want only commit offered defaults, then more feasible should be any automatic IP protocol detection, or leave both options unchecked.

Comment 1 Dan Williams 2010-05-03 10:05:02 UTC

*** This bug has been marked as a duplicate of bug 567978 ***


Note You need to log in before you can comment on or make changes to this bug.