Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 588052 - rd_NO_LUKS not working
rd_NO_LUKS not working
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-02 08:11 EDT by Michael Monreal
Modified: 2010-05-03 12:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 12:58:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2010-05-02 08:11:36 EDT
I have installed F13 beta (+updates). rd_NO_LUKS was added to the kernel line automatically. I have one (non root) partition that is LUKS encrypted, however, I still get a password prompt during boot.
Comment 1 Harald Hoyer 2010-05-03 04:38:07 EDT
Maybe during boot, but not in the dracut phase. Might be already in the real root from rc.sysinit. Fix your /etc/crypttab.
Comment 2 Michael Monreal 2010-05-03 12:58:09 EDT
Ah... I hadn't modified the file myself, looks like anaconda did this during installation. Also, I was not aware of the dracut<->later boot phases or that partitons can be unlocked in both phases.

Note You need to log in before you can comment on or make changes to this bug.