Bug 588067 - ntpstat reports accuracy unkown when at good stratum
ntpstat reports accuracy unkown when at good stratum
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
: 590808 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-02 09:50 EDT by Bernd Stramm
Modified: 2016-06-14 04:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: ntp-4.2.6p1-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-20 14:41:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Stramm 2010-05-02 09:50:31 EDT
Description of problem:

ntpstat always reports "accuracy unknown" when synchronized


Version-Release number of selected component (if applicable):
from yum info ntp:
Name       : ntp
Arch       : x86_64
Version    : 4.2.6p1
Release    : 1.fc13

How reproducible:
$ ntpstat


Steps to Reproduce:
1. wait for ntpd to synchronize
2. type ntpstat

  
Actual results:

$ ntpstat
synchronised to NTP server (206.248.172.208) at stratum 3 
accuracy unknown
poll interval unknown


Expected results:

$ ntpstat
synchronised to NTP server (192.43.244.18) at stratum 2 
   time correct to within 454 ms
   polling server every 64 s



Additional info:

$ uname -a
Linux pirx.localdomain 2.6.33.2-57.fc13.x86_64 #1 SMP Tue Apr 20 08:57:50 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

$ ntpdc -p
     remote           local      st poll reach  delay   offset    disp
=======================================================================
=zeus.yocum.org  192.168.1.152    2   64   77 0.05037 -0.023448 0.43671
=87.117.229.237  192.168.1.152    2   64   77 0.11678 -0.030063 0.43495
*ox.eicat.ca     192.168.1.152    2   64   77 0.01974 -0.030126 0.43410
Comment 1 Miroslav Lichvar 2010-05-03 06:03:28 EDT
Looks like some of the system variables have changed their names in the latest ntpq protocol.

Should be easy to fix.
Comment 2 Miroslav Lichvar 2010-05-11 04:12:16 EDT
*** Bug 590808 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2010-05-13 09:41:07 EDT
ntp-4.2.6p1-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ntp-4.2.6p1-2.fc13
Comment 4 Fedora Update System 2010-05-15 16:34:48 EDT
ntp-4.2.6p1-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ntp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ntp-4.2.6p1-2.fc13
Comment 5 Fedora Update System 2010-05-20 14:41:27 EDT
ntp-4.2.6p1-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 jhen_roces 2016-06-14 04:50:27 EDT
Hi,

I  also  have the same problem. I am using RedHat as OS.

[root@server[] /etc]
# ntpstat
synchronised to NTP server (10.10.10.10) at stratum 2 
accuracy unknown
poll interval unknown

[root@glspesold[] /etc]
# uname -a
Linux server 2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64 x86_64 x86_64 GNU/Linux


Please advise. Thanks!!

Note You need to log in before you can comment on or make changes to this bug.