This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 58809 - Asian fonts are not displayed in PS or PDF output
Asian fonts are not displayed in PS or PDF output
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: docbook-utils (Show other bugs)
7.2
All Linux
high Severity high
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-24 17:54 EST by Tammy Fox
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:19:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test SGML file with Japanese fonts (515 bytes, text/plain)
2002-01-24 18:18 EST, Tammy Fox
no flags Details
test SGML file - Korean (487 bytes, text/plain)
2002-01-24 18:19 EST, Tammy Fox
no flags Details
test SGML file - Traditional Chinese (474 bytes, text/plain)
2002-01-24 18:23 EST, Tammy Fox
no flags Details
test SGML file - Simplified Chinese (478 bytes, text/plain)
2002-01-24 18:23 EST, Tammy Fox
no flags Details

  None (edit)
Description Tammy Fox 2002-01-24 17:54:07 EST
If lang is set to ja, ko, zh_cn, or zh_tw, the PS
or PDF outputs are not correct. Ghostscript can
convert PS to PDF fine if the PS has correct fonts,
so it would be ideal if docbook2ps foo.sgml worked.
Comment 1 Tammy Fox 2002-01-24 18:18:32 EST
Created attachment 43415 [details]
test SGML file with Japanese fonts
Comment 2 Tammy Fox 2002-01-24 18:19:33 EST
Created attachment 43416 [details]
test SGML file - Korean
Comment 3 Tammy Fox 2002-01-24 18:23:16 EST
Created attachment 43417 [details]
test SGML file - Traditional Chinese
Comment 4 Tammy Fox 2002-01-24 18:23:33 EST
Created attachment 43418 [details]
test SGML file - Simplified Chinese
Comment 5 Tim Waugh 2002-01-25 13:03:09 EST
Note to self: compare with HTML output, and remember to set correct character
encoding in browser.
Comment 6 Tammy Fox 2002-01-25 14:41:42 EST
The attached file testing-ja.sgml should have the lang set to ja, not ja_JP.
Comment 7 Tim Waugh 2002-01-26 13:55:28 EST
It does the same thing via PassiveTeX.  I've asked the jadetex maintainer about it.
Comment 8 Tim Waugh 2002-02-19 10:02:42 EST
This seems to be hard to fix. :-(

When trying to build (for example) a format file for JadeTeX with pTeX, I get
errors that suggest that babel isn't available: but I can't figure out why not.
Comment 9 Bill Nottingham 2006-08-07 16:00:20 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 10 Bill Nottingham 2006-10-18 13:19:06 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.