Bug 58810 - Engines are not built as shared objects
Summary: Engines are not built as shared objects
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gtk-engines (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-24 23:08 UTC by Stefan Sorensen
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 23:08:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stefan Sorensen 2002-01-24 23:08:20 UTC
The engines are built as static modules and not dynamic as they should.
Removing acinclude.m4 before running libtoolize fixes the problem.


Any reason for using automake1.4? It builds fine with automake-1.5-8.

Comment 1 Owen Taylor 2002-01-24 23:50:30 UTC
Next build of gtk-engines should fix this bug.

The reason for using automake-1.4 is that there is no reason to
deviate from the upstream package and risk incompatiblities.



Note You need to log in before you can comment on or make changes to this bug.