Bug 588134 - cciss raid rescan fails with: write error: Invalid argument
Summary: cciss raid rescan fails with: write error: Invalid argument
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.4
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-02 20:06 UTC by Juha Tuomala
Modified: 2018-11-27 20:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-18 15:27:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Juha Tuomala 2010-05-02 20:06:45 UTC
Description of problem:
After expanding a cciss hw raid array with new disks, the new disc size is visible in Linux, but the kernel doesn't update its understanding of physical volume size, not even triggered manually via cciss driver. 


Version-Release number of selected component (if applicable):
kernel-2.6.18-164.15.1.el5.centos.plus.x86_64


How reproducible:
Always.

Steps to Reproduce:
1. Expand cciss disks with hpacucli
2. echo "rescan" > /proc/drivers/cciss/cciss0
3. error is given
  
Actual results:
Cannot on-line pvresize the block device.

# echo "rescan" > /proc/driver/cciss/cciss0 
-bash: echo: write error: Invalid argument

Rebooting the system makes expanded disks visible.

Expected results:
working pvresize, lvextend, etc.

Additional info:
This is a centos 5 box. p800 controller.

Comment 1 Alexey Kurnosov 2010-09-27 15:24:47 UTC
Confirm this bug for Red Hat Enterprise Linux Server release 5.5 (Account #1292125).
2.6.18-194.8.1.el5 #1 SMP Wed Jun 23 10:52:51 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux.

Comment 2 Christian Ekstam 2011-10-28 08:38:29 UTC
Also confirmed on CentOS 5 2.6.18-194.26.1.el5 x86_64 Smart Array P400/Hardware Revision: Rev D/Firmware Version: 7.22. 
2.6.18-194.26.1.el5 #1 SMP Tue Nov 9 12:54:20 EST 2010 x86_64 x86_64 GNU/Linux

Comment 3 Chris Williams 2012-01-18 15:27:47 UTC
It has been some time since this BZ was updated and both customer cases are closed. If this is still an issue please open a case with Red Hat Support. Closing NOTABUG.

Comment 4 Juha Tuomala 2012-01-18 15:43:05 UTC
Which 'customer cases'? I've not opened any customer case about this nor any of such has been closed.

You claim that this is not a bug. Could you please elaborate that?


Note You need to log in before you can comment on or make changes to this bug.