Bug 588184 - "Refresh Components/Versions/Milestones" should not reload the page
Summary: "Refresh Components/Versions/Milestones" should not reload the page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Query/Bug List
Version: 3.6
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeff Fearn 🐞
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-03 03:07 UTC by Matt McCutchen
Modified: 2012-05-30 05:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-30 05:38:54 UTC


Attachments (Terms of Use)

Description Matt McCutchen 2010-05-03 03:07:59 UTC
Description of problem:
Currently, the "Refresh Components/Versions/Milestones" button reloads the page, and any field changes made on the old page after clicking the button are lost.  Please make it work without reloading the page, so that the user can continue setting fields while waiting for the component list to download.  This will shave a few seconds off the search process for some users.

The implementation may be as simple as restoring the original AJAX update code but running it when the button is pressed rather than when the classification or product field is changed.

How reproducible:
Always

Steps to Reproduce:
1. Go to https://bugzilla.redhat.com/query.cgi
2. Select classification "Fedora" and product "Fedora".
3. Click "Refresh Components/Versions/Milestones".
4. While waiting, clear the status field.
  
Actual results:
The page reloads, and the status field reverts to the default of "NEW" and "ASSIGNED".

Expected results:
The component list updates, but the status field remains clear.

Comment 1 David Lawrence 2010-08-25 21:43:59 UTC
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team

Comment 2 Matt McCutchen 2010-08-25 21:50:30 UTC
The problem is the same in Bugzilla 3.6.

Comment 3 David Lawrence 2010-08-25 22:01:34 UTC
Bugzilla originally came with jscript that did this type of thing when you selected a product, but as Red Hat's component lists per product grew the jscript that was downloaded to the user's browser grew significantly. Fedora for example has 6000+ components for one product. This caused Firefox and others to slow to a crawl and made the query.cgi page unusable. The refresh button was added so the jscript could be removed. This is more an issue with query.cgi needing to be reworked completely to help with this problem as well as other problems making it not very intuitive. Upstream has some improvements in the upcoming 4.0 release but not sure it addresses the large component list issue. We will need to work with the upstream to figure out how to solve this as I am sure more Bugzilla installations will start to run into this as well.

Dave

Comment 4 Jeff Fearn 🐞 2012-05-30 04:47:50 UTC
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.

Comment 5 Matt McCutchen 2012-05-30 05:38:54 UTC
query.cgi is back to bundling the entire component list with the initial page, so this bug does not apply.


Note You need to log in before you can comment on or make changes to this bug.