Bug 58821 - ES40 install hangs at "Performing post installation configuration"
ES40 install hangs at "Performing post installation configuration"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Beth Uptagrafft
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-25 01:40 EST by john.goshdigian
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-07 17:21:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john.goshdigian 2002-01-25 01:40:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en]C-CCK-MCD BA45DSL  (Windows NT 5.0; U)

Description of problem:
On 2 different ES40s, the installation appears to copy the appropriate packages, but upon completing the copy, the install hangs with the
message "Performing post installation configuration" about 50% complete.
On 1 ES40, tried 2 different disk drives.
at the console hang point (which is on Screen Alt F7), one can Ctrl, Alt F2 to a shell. 
From a ps in the shell, one observes about 30 processes, 2 interesting observations from # ps:
/usr/bin/kudzu -q
/usr/bin/eepro100-diag -f -G3 -u -w

Why is eepro100-diag active??

If you'd like me to check something else out during the install's hung state, please email or call me.
john.goshdigian@compaq.com - 603.884.1488
Little by little, I will try to kill processes while hung. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install beta1 from CD on an ES40 with at least 2GB of mem
2. Do not specify much swap space (e.g. 512MB) on the drive to be installed onto
3. Witness hang after packages copied to disk drive
	

Actual Results:  Witness hang after packages copied to disk drive, with message
Performing post installatin configuration

Expected Results:  installation to complete.

Additional info:

Also, during the hung install, bottom lines of the display on the Alt F3 screen:
* looking for USB mouse
* ddcprobe failed
* ddcprobe failed
* anaconda floppy device fd0
* Detected 2016M of mem
* Swap attempt 1000M to 2000M
* Mount of /proc/bus/usb failed                #! (last line on the screen at hung point)

Note on this ES40, the system has 2GB of mem, and installation is onto a 4GB drive.
On 2nd ES40, system has 4GB of mem, and installation is onto an 18GB drive.
Comment 1 George France 2002-01-25 15:34:39 EST
It is the eepro100-diag program.  If you kill it, the installation continues
until it fails during reboot due to bad partitioning, which was reported
earlier.

--George
Comment 2 john.goshdigian 2002-02-05 17:03:18 EST
Indeed, killing the eepro100-diag program, does allow the install to complete.
So it appears there is a bug with the eepro100-diag program.
Comment 3 Bill Nottingham 2002-02-25 16:34:50 EST
What happens if you run:

/usr/bin/eepro100-diag -f -G3 -w -w

after booting?
Comment 4 john.goshdigian 2002-03-07 17:21:34 EST
I didn't get to try this on the beta1, but here's what's returned on the ES40
with the eepro100-diag in the beta2 ISOs:
# /usr/sbin/eepro100-diag -f -G3 -w -w
eepro100-diag.c:v2.05 6/13/2001 Donald Becker (becker@scyld.com)
 http://www.scyld.com/diag/index.html
Index #1: Found a Intel i82557/8/9 EtherExpressPro100 adapter at 0x8000.
Writing fffd to configuration word 10.
 Use '-a' or '-aa' to show device registers,
     '-e' to show EEPROM contents, -ee for parsed contents,
  or '-m' or '-mm' to show MII management registers.

Comment 5 Phil Copeland 2002-04-03 17:33:58 EST
While we don't appear to have a fix for the eepro100-diag problem the
distribution will no longer ship with it to avoid the eeprom getting munched.

(aka "don't do that then")

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.