Bug 588252 - Cannot create new folder from the message filter dialog
Summary: Cannot create new folder from the message filter dialog
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-03 10:08 UTC by Christoph Wickert
Modified: 2010-05-03 13:16 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-05-03 13:16:13 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 593890 None None None Never

Description Christoph Wickert 2010-05-03 10:08:16 UTC
Description of problem:
It is impossible to add new folders from the 'Message Filters' dialog.

Version-Release number of selected component (if applicable):
evolution-2.30.1-2.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. Main Window: Edit -> Message Filters
2. 'Message Filters' dialog: Add
3. 'Add rule' dialog: Move to folder -> <click here to select a folder>
4  'Selct folder' dialog: New
  
Actual results:
'Create Folder' dialog appears, 'Folder name' field has focus, but you cannot type. In Fact, everything in the dialog is blocked, 'Cancel' doesn't work ether because the focus still is in the 'Select Folder' dialog below. You need to first click 'Cancel' in 'Select Folder', then you can close the 'Folder Name' dialog.

Expected results:
It should be possible to create net folders from the 'Add filters' dialog as it was before.

Additional info:
According to https://bugzilla.gnome.org/show_bug.cgi?id=593890 the problem already existed in 2.28.x, but I never noticed it.

Comment 1 Milan Crha 2010-05-03 13:16:13 UTC
Thanks for a bug report and finding the relevant upstream bug. As this is not Fedora specific I'm closing this as upstream, Please see the upstream bug report for more updates.


Note You need to log in before you can comment on or make changes to this bug.