Bug 588254 - virt-manager: Traceback prevents reopening remote VNC session
virt-manager: Traceback prevents reopening remote VNC session
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 06:11 EDT by Daniel
Modified: 2010-05-27 16:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 16:03:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager.log (2.18 KB, application/octet-stream)
2010-05-03 06:11 EDT, Daniel
no flags Details

  None (edit)
Description Daniel 2010-05-03 06:11:29 EDT
Created attachment 410936 [details]
virt-manager.log

Description of problem:
I'm using virt-manager on a fedora 12 desktop to manage a remote libvirt host using SSH.
Since I've upgraded virt-manager to version 0.8.4 (using this repo: http://jforbes.fedorapeople.org/virt-preview/f13/x86_64/), I cannot re-open a VNC console. The first time I open the VNC session for one guest, it's working fine, if I close the window, and try to re-open it, I have a black window.

The problem seems to be that virt-manager do not create the SSH tunnel anymore.


Attached is a snippet of my virt-manager log:

11:52:44: I open the VNC console for one guest. We can see the tunnel being created, everything works fine

11:53:04: I close the window. We can see that the number of window is decremented, then, we have a traceback


11:53:12: I try to re-open the VNC console, the window counter is incremented, but the tunnel is not created anymore. I just have a black window instead of the VNC session.

I have to restart virt-manager to be able to open the VNC console again.

Version-Release number of selected component (if applicable):

virt-manager 0.8.4 from http://jforbes.fedorapeople.org/virt-preview/f13/x86_64/

How reproducible:
Always

Steps to Reproduce:
1. open a VNC session to a remote libvirt host using SSH
2. close the window
3. try to re-open the VNC session for the same guest
  
Actual results:
VNC session do not work

Expected results:
VNC session should work

Additional info:
Comment 1 Cole Robinson 2010-05-05 15:51:29 EDT
Fixed upstream:

http://hg.fedorahosted.org/hg/virt-manager/rev/c206b12a8c7a

Moving to rawhide where the fix needs to be built.
Comment 2 Cole Robinson 2010-05-27 16:03:00 EDT
Thanks for the report, Next rawhide compose should contain and updated virt-manager which fixes this issue.

Note You need to log in before you can comment on or make changes to this bug.