Bug 588314 - system freezes after switching of logical display position in gnome-display-properties
system freezes after switching of logical display position in gnome-display-p...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
card_GM45
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 09:14 EDT by Lubos Kocman
Modified: 2010-06-23 02:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: kernel-2.6.32-33.el6.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-23 02:25:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (465.90 KB, text/plain)
2010-05-03 10:08 EDT, Lubos Kocman
no flags Details
Xorg.0.log (108.03 KB, text/plain)
2010-05-03 10:08 EDT, Lubos Kocman
no flags Details
Xorg.0.log.old (95.81 KB, text/plain)
2010-05-03 10:09 EDT, Lubos Kocman
no flags Details
log from working session (54.59 KB, text/plain)
2010-05-03 10:44 EDT, Ales Zelinka
no flags Details
log from session that froze the computer (83.77 KB, text/plain)
2010-05-03 10:45 EDT, Ales Zelinka
no flags Details
/var/log/messages x60s (451.61 KB, text/plain)
2010-05-05 09:24 EDT, Lubos Kocman
no flags Details
Xorg.0.log x60s (96.58 KB, text/plain)
2010-05-05 09:24 EDT, Lubos Kocman
no flags Details

  None (edit)
Description Lubos Kocman 2010-05-03 09:14:54 EDT
Description of problem:

System completely freezes after switching position of virtual display in gnome-display-properties.


Version-Release number of selected component (if applicable):

control-center-2.28.1-16.el6.x86_64
xorg-x11-drv-intel-2.10.902-1.el6.x86_64
libXrandr-1.3.0-4.el6.x86_64

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

How reproducible:


Steps to Reproduce:
1. Boot with dual displays after clean install of clean install of RHEL 6 beta.
2. Switch virtual position of any display (e.g. from left to right)
3. Click apply
  
Actual results:

System completely freezes not responding on any user actions. Switching to console doesn't work either.

Expected results:

Switched position (left to right) of virtual displays.

Additional info:

System crashes any time (after applying configuration via gnome-display-properties) when booted by using dual screens.
Comment 1 Lubos Kocman 2010-05-03 09:15:53 EDT
Hardware with this problem is Thinkpad T400.
Comment 3 Matěj Cepl 2010-05-03 09:59:51 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

If you are able to get to the frozen computer somehow (ssh from another computer?), please attach

* your X server config file (/etc/X11/xorg.conf, if available),
* output of the dmesg command,
* system log (/var/log/messages), and
* X server log file (/var/log/Xorg.*.log)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Lubos Kocman 2010-05-03 10:08:04 EDT
Created attachment 411004 [details]
/var/log/messages
Comment 6 Lubos Kocman 2010-05-03 10:08:42 EDT
Created attachment 411005 [details]
Xorg.0.log
Comment 7 Lubos Kocman 2010-05-03 10:09:07 EDT
Created attachment 411009 [details]
Xorg.0.log.old
Comment 8 Lubos Kocman 2010-05-03 10:10:08 EDT
Hello please see attached files for more info. Xorg.conf is not available on mentioned system.
Comment 9 Ales Zelinka 2010-05-03 10:43:19 EDT
I have very similar problem on Lenovo T61: 

external monitor connected to the laptop via dock.
The default (mirror) mode works perfect but when I try to de-couple the displays, there's about 50% change that my laptop freezes completely.

Command I use:
xrandr --output LVDS1 --auto --preferred --output VGA1 --auto --left-of LVDS1 --rotate left

xrandr output when it actually worked:
 Screen 0: minimum 320 x 200, current 2704 x 1280, maximum 8192 x 8192
LVDS1 connected 1680x1050+1024+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1680x1050      60.0*+   50.0  
   1400x1050      60.0  
   1280x1024      60.0  
   1280x960       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1024x1280+0+0 left (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0*+   75.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
DVI1 disconnected (normal left inverted right x axis y axis)

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)


I have no xorg.conf, logs will follow.
Comment 10 Ales Zelinka 2010-05-03 10:44:31 EDT
Created attachment 411020 [details]
log from working session

it worked this time
Comment 11 Ales Zelinka 2010-05-03 10:45:05 EDT
Created attachment 411021 [details]
log from session that froze the computer
Comment 12 RHEL Product and Program Management 2010-05-03 10:50:30 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 13 Lubos Kocman 2010-05-05 09:24:11 EDT
Created attachment 411595 [details]
/var/log/messages x60s
Comment 14 Lubos Kocman 2010-05-05 09:24:52 EDT
Created attachment 411596 [details]
Xorg.0.log x60s
Comment 15 Lubos Kocman 2010-05-05 09:36:16 EDT
Hello I tried to switch multiple "presentation/display modes" on Thinkpad X60s with extended display. And I run into the same issue as on previously mentioned T400.

Steps to reproduce:

1) Plug in extended display via vga port to X60s
2) Tap Few times Fn+F7 to test all possible profiles
    - Extended Display -- OK
    - Mirror -- OK
    - Laptop only -- OK
    - DISPLAY only (+ laptop console???) -- OK
    - freeze (possibly again extended screen)
Info about machine

# xrandr

Screen 0: minimum 320 x 200, current 2704 x 1050, maximum 4096 x 4096
LVDS1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 246mm x 185mm
   1024x768       50.0*+   60.0     40.0  
   800x600        60.3     56.2  
   640x480        60.0     59.9  
VGA1 connected 1680x1050+1024+0 (normal left inverted right x axis y axis) 474mm x 296mm
   1680x1050      60.0*+
   1600x1200      60.0  
   1400x1050      60.0  
   1280x1024      75.0  
   1440x900       75.0     59.9  
   1280x960       60.0  
   1280x800       59.8  
   1152x864       75.0  
   1024x768       75.1     75.0     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  


# lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)


Xorg packages:

# rpm -qa | grep xorg

xorg-x11-xinit-1.0.9-13.el6.i686
xorg-x11-docs-1.3-6.1.el6.noarch
xorg-x11-drv-void-1.3.0-4.el6.i686
xorg-x11-xauth-1.0.2-7.1.el6.i686
xorg-x11-drv-penmount-1.4.0-5.el6.i686
xorg-x11-drv-mouse-1.5.0-4.el6.i686
xorg-x11-drv-glint-1.2.4-1.1.el6.i686
xorg-x11-drv-qxl-0.0.12-2.1.el6.i686
xorg-x11-drv-fpit-1.3.0-5.el6.i686
xorg-x11-drv-nouveau-0.0.16-5.20100318gite2146d3.1.el6.i686
xorg-x11-drv-apm-1.2.2-1.1.el6.i686
xorg-x11-drv-hyperpen-1.3.0-4.el6.i686
xorg-x11-drv-neomagic-1.2.4-2.el6.i686
xorg-x11-drv-vmmouse-12.6.5-3.el6.i686
xorg-x11-drv-vmware-10.16.7-2.1.el6.i686
xorg-x11-server-Xorg-1.7.6-3.el6.i686
xorg-x11-drv-wacom-0.10.5-2.el6.i686
xorg-x11-drv-r128-6.8.1-2.el6.i686
xorg-x11-drv-elographics-1.2.3-5.el6.i686
xorg-x11-drv-aiptek-1.3.0-2.el6.i686
xorg-x11-drv-sisusb-0.9.3-1.1.el6.i686
xorg-x11-drv-v4l-0.2.0-3.el6.3.i686
xorg-x11-drv-voodoo-1.2.3-1.1.el6.i686
xorg-x11-drv-cirrus-1.3.2-1.1.el6.i686
xorg-x11-drv-sis-0.10.2-1.1.el6.i686
xorg-x11-drv-siliconmotion-1.7.3-1.1.el6.i686
xorg-x11-drv-nv-2.1.15-4.el6.i686
xorg-x11-proto-devel-7.4-35.el6.noarch
xorg-x11-font-utils-7.2-10.el6.i686
xorg-x11-drv-mutouch-1.2.1-5.el6.i686
xorg-x11-drv-vesa-2.2.1-1.1.el6.i686
xorg-x11-drv-intel-2.10.902-1.el6.i686
xorg-x11-drv-openchrome-0.2.904-1.el6.i686
xorg-x11-drv-i740-1.3.2-1.1.el6.i686
xorg-x11-drv-tdfx-1.4.3-1.1.el6.i686
xorg-x11-drv-trident-1.3.3-1.1.el6.i686
xorg-x11-drv-rendition-4.2.2-4.1.el6.i686
xorg-x11-drv-ati-6.13.0-3.el6.i686
xorg-x11-drv-mach64-6.8.2-1.1.el6.i686
xorg-x11-drv-keyboard-1.4.0-3.el6.i686
xorg-x11-drv-acecad-1.4.0-2.el6.i686
xorg-x11-drv-dummy-0.3.3-1.el6.i686
xorg-x11-drv-mga-1.4.11-1.1.el6.i686
xorg-x11-drv-ast-0.89.9-1.1.el6.i686
xorg-x11-drv-savage-2.3.1-1.1.el6.i686
xorg-x11-server-common-1.7.6-3.el6.i686
xorg-x11-xkb-utils-7.4-6.el6.i686
xorg-x11-server-utils-7.4-15.el6.i686
xorg-x11-utils-7.4-7.el6.i686
xorg-x11-drv-ati-firmware-6.13.0-3.el6.noarch
xorg-x11-drivers-7.3-13.2.el6.i686
xorg-x11-drv-evdev-2.3.2-6.el6.i686
xorg-x11-drv-synaptics-1.2.1-1.el6.i686
xorg-x11-drv-i128-1.3.3-1.1.el6.i686
xorg-x11-drv-s3virge-1.10.4-1.1.el6.i686
xorg-x11-drv-fbdev-0.4.1-1.1.el6.i686
xorg-x11-drv-geode-2.11.4.1-1.el6.i686


Mentioned command: 

xrandr --output LVDS1 --auto --preferred --output VGA1 --auto --left-of LVDS1

produces the same thing.

See attached Xorg.0.log.x60 messages.x60
Comment 16 Petr Šplíchal 2010-05-10 05:40:42 EDT
I experienced a similar freeze when I changed a position of the
two monitors in a way that they are not aligned, e.g. like this:

                 +----------+
                 |          |
    +------------+          |
    |            |          |
    |            |          |
    |            |          |
    |            |          |
    +------------+          |
                 |          |
                 +----------+

Works fine when monitors are aligned like this:

    +------------+----------+
    |            |          |
    |            |          |
    |            |          |
    |            |          |
    +------------+          |
                 |          |
                 |          |
                 +----------+
Comment 17 Adam Jackson 2010-06-16 14:52:32 EDT
Anyone who can reproduce this with kernel 2.6.32-33 or later?
Comment 18 Lubos Kocman 2010-06-17 02:41:49 EDT
Hello issue seems to be fixed, as  I was able to reproduce this any time and now not.


My configuration:

Thinkpad T400

xorg-x11-drv-intel-2.11.0-5.el6.x86_64
xorg-x11-server-utils-7.4-15.el6.x86_64
xorg-x11-server-common-1.7.7-11.el6.x86_64
xorg-x11-server-Xorg-1.7.7-11.el6.x86_64
kernel-2.6.32-33.el6.x86_64
Comment 19 Dave Airlie 2010-06-23 02:25:16 EDT
reported fixed by initial reporter

Note You need to log in before you can comment on or make changes to this bug.