Bug 588350 - bug in the ALSA driver 'snd_hda_intel'
Summary: bug in the ALSA driver 'snd_hda_intel'
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Jaroslav Kysela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-03 14:30 UTC by Thomas Spura
Modified: 2010-09-02 18:00 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 10:23:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'LC_ALL=C pulseaudio -vvv' (74.82 KB, text/plain)
2010-05-03 14:30 UTC, Thomas Spura
no flags Details

Description Thomas Spura 2010-05-03 14:30:50 UTC
Created attachment 411015 [details]
'LC_ALL=C pulseaudio -vvv'

Description of problem:
Sometimes, pulseaudio crashes and is not able to start again properly.
Strangely, this only happens 7-8 out of 10 reboots...

Attached is the output of:
'LC_ALL=C pulseaudio -vvv'

Version-Release number of selected component (if applicable):
pulseaudio-0.9.21-6.fc13.x86_64

How reproducible:
7 out of 10 reboots

Steps to Reproduce:
1. Just boot up and loginto xfce or gnome

Comment 1 Thomas Spura 2010-05-03 14:33:11 UTC
Quoted from the attachment:
E: alsa-util.c: snd_pcm_delay() returned a value that is exceptionally large:
872395264 bytes (4945551 ms).
E: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'.
Please report this issue to the ALSA developers.

Is pulseaudio the right component?

Comment 2 Thomas Spura 2010-05-06 09:02:51 UTC
(In reply to comment #1)
> Is pulseaudio the right component?    

alsa-util should be a better component...

Comment 3 Jaroslav Kysela 2010-05-07 09:42:33 UTC
Please, could you try the latest ALSA driver?

# wget -O alsa-compile.sh http://www.alsa-project.org/alsa-compile.sh
# chmod 755 alsa-compile.sh

Compile and insert new ALSA kernel modules:

# ./alsa-compile.sh --driver --kmodules

Note that above commands do not replace the Fedora ALSA kernel modules in /lib/modules tree. Look to URL bellow for more details.

http://www.alsa-project.org/main/index.php/Driver_Compilation

Comment 4 Thomas Spura 2010-05-11 11:16:20 UTC
(In reply to comment #3)
> Please, could you try the latest ALSA driver?

It seems not ;)

make -C /lib/modules/2.6.34-0.28.rc3.git3.fc14.x86_64/source SUBDIRS=/tmp/alsa-compile-script/alsa-driver-1.0.23.10.gc720f.50.gad2df  CPP="gcc -E" CC="gcc" modules
make[1]: Entering directory `/usr/src/kernels/2.6.34-0.28.rc3.git3.fc14.x86_64'
Makefile:535: /usr/src/kernels/2.6.34-0.28.rc3.git3.fc14.x86_64/arch//Makefile: No such file or directory
make[1]: *** No rule to make target `/usr/src/kernels/2.6.34-0.28.rc3.git3.fc14.x86_64/arch//Makefile'.  Stop.
make[1]: Leaving directory `/usr/src/kernels/2.6.34-0.28.rc3.git3.fc14.x86_64'
make: *** [compile] Error 2


Should I send this out to the mailing list or is it my fault, that I'm running an rawhide kernel on F-13?

Comment 5 Mads Kiilerich 2010-06-02 08:43:15 UTC
(cross reference: the compilation issue also popped up in the threat starting at http://mailman.alsa-project.org/pipermail/alsa-devel/2010-June/028272.html )

Comment 6 Raymond 2010-06-27 05:27:57 UTC
(In reply to comment #3)
> Please, could you try the latest ALSA driver?
> 
> # wget -O alsa-compile.sh http://www.alsa-project.org/alsa-compile.sh
> # chmod 755 alsa-compile.sh
> 
> Compile and insert new ALSA kernel modules:
> 
> # ./alsa-compile.sh --driver --kmodules
> 
> Note that above commands do not replace the Fedora ALSA kernel modules in
> /lib/modules tree. Look to URL bellow for more details.
> 
> http://www.alsa-project.org/main/index.php/Driver_Compilation    

I can confirm that both alsa-driver-1.0.23 and  "./alsa-compile.sh --driver --kmodules" fail on x86 with same error


http://thread.gmane.org/gmane.linux.alsa.devel/73596/focus=73602

Comment 7 Thomas Spura 2010-06-27 09:41:20 UTC
It seems, like this problem is gone now.

Can't find any problems in /var/log/messages anymore.

Will see again this week, and if I can't reproduce this, I'll close this...

Comment 8 Mads Kiilerich 2010-06-29 09:26:21 UTC
Thomas: Can you compile alsa-driver now? I still can't ...

Comment 9 Thomas Spura 2010-06-29 10:23:32 UTC
(In reply to comment #8)
> Thomas: Can you compile alsa-driver now? I still can't ...    

No, it still fails with the same error like in comment #6.

But this bug in snd_hda_intel seems to be gone for me, so closing as CURRENTRELEASE.


(If you want to leave this bug open as a tracker for the compilation failure, feel free to reopen.)

Comment 10 Raymond 2010-06-29 23:05:29 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Is pulseaudio the right component?    
> 
> alsa-util should be a better component...    

alsa-util.c is belonged to pulseaudio

http://git.0pointer.de/?p=pulseaudio.git;a=blob;f=src/modules/alsa/alsa-util.c

Have you try this patch  ?

http://git.alsa-project.org/?p=alsa-plugins.git;a=commitdiff;h=1675414eca06dcfc20899adf104ace05acfe26a0;hp=434ab6c8b6ee24f6a692a7ccc77f08ffd9aa8def

Comment 11 Raymond 2010-06-30 02:17:33 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Please, could you try the latest ALSA driver?
> 
> It seems not ;)
> 
> make -C /lib/modules/2.6.34-0.28.rc3.git3.fc14.x86_64/source
> SUBDIRS=/tmp/alsa-compile-script/alsa-driver-1.0.23.10.gc720f.50.gad2df 
> CPP="gcc -E" CC="gcc" modules
> make[1]: Entering directory `/usr/src/kernels/2.6.34-0.28.rc3.git3.fc14.x86_64'
> Makefile:535: /usr/src/kernels/2.6.34-0.28.rc3.git3.fc14.x86_64/arch//Makefile:
> No such file or directory
> make[1]: *** No rule to make target
> `/usr/src/kernels/2.6.34-0.28.rc3.git3.fc14.x86_64/arch//Makefile'.  Stop.
> make[1]: Leaving directory `/usr/src/kernels/2.6.34-0.28.rc3.git3.fc14.x86_64'
> make: *** [compile] Error 2
> 
> 
> Should I send this out to the mailing list or is it my fault, that I'm running
> an rawhide kernel on F-13?    

seem only Fedora 13 has this bug 

I can compile alsa-driver-1.0.23 in Fedora 10

Looking at Makefile , it seem to be an unified Makefile for x86 and 64

and there is warning about the compiler in Fedora 13

Comment 12 Peter 2010-08-31 18:18:59 UTC
I confirm this bug in fc13.x86_6:
I downloaded ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.23.tar.bz2
[blacksun@blacksun-laptop alsa-driver-1.0.23]$ make
make[1]: Leaving directory `/home/blacksun/alsa-driver-1.0.23'
make -C /lib/modules/2.6.33.8-149.fc13.x86_64/source SUBDIRS=/home/blacksun/alsa-driver-1.0.23  CPP="gcc -E" CC="gcc" modules
make[1]: Entering directory `/usr/src/kernels/2.6.33.8-149.fc13.x86_64'
Makefile:535: /usr/src/kernels/2.6.33.8-149.fc13.x86_64/arch//Makefile: No such file or directory
make[1]: *** No rule to make target `/usr/src/kernels/2.6.33.8-149.fc13.x86_64/arch//Makefile'.  Stop.
make[1]: Leaving directory `/usr/src/kernels/2.6.33.8-149.fc13.x86_64'
make: *** [compile] Error 2
[blacksun@blacksun-laptop alsa-driver-1.0.23]$ uname -a
Linux blacksun-laptop 2.6.33.8-149.fc13.x86_64 #1 SMP Tue Aug 17 22:53:15 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

Comment 13 Jaroslav Kysela 2010-08-31 20:45:30 UTC
The alsa-compile.sh and build system is fixed for latest Fedora kernels. Use instructions in comment#3 to build the latest ALSA code.

Comment 14 Raymond 2010-08-31 23:29:13 UTC
it still fail 

however , it can be build after yum remove kernel-devel ( seem there are two versions of kernel-devel removed ) and yum install kernel-devel

Comment 15 Peter 2010-09-02 18:00:43 UTC
Thanks Jaroslav!
For me it works after installing the latest kernel-devel and follow the the instructions on http://www.alsa-project.org/main/index.php/Driver_Compilation
cd alsa-driver* && cd utils && wget -O alsa-compile.sh http://www.alsa-project.org/alsa-compile.sh

Be sure to use Internal Audio analog Surround 4.0 since HDMI doesn't work yet.
Also; you won't get surround; but simple stereo.


Note You need to log in before you can comment on or make changes to this bug.