Bug 588364 - Can't install rubygem-hoe
Can't install rubygem-hoe
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: rubygem-hoe (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Stahnke
Fedora Extras Quality Assurance
:
Depends On: 589696 589801
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 10:59 EDT by Lubomir Rintel
Modified: 2010-09-22 06:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 06:57:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Rintel 2010-05-03 10:59:21 EDT
Description of problem:

rubygem-hoe-2.5.0-2.el5.noarch from epel has depsolving problems
  --> Missing Dependency: rubygem(minitest) >= 1.4.2 is needed by package rubygem-hoe-2.5.0-2.el5.noarch (epel)
rubygem-hoe-2.5.0-2.el5.noarch from epel has depsolving problems
  --> Missing Dependency: rubygem(gemcutter) >= 0.2.1 is needed by package rubygem-hoe-2.5.0-2.el5.noarch (epel)
rubygem-hoe-2.5.0-2.el5.noarch from epel has depsolving problems
  --> Missing Dependency: rubygem(rubyforge) >= 2.0.3 is needed by package rubygem-hoe-2.5.0-2.el5.noarch (epel)
Comment 1 Michael Stahnke 2010-05-03 20:28:50 EDT
Hmm.  My fault for missing some deps.  This works on my test system, but I realized I had built some additional packages in preparation for Sinatra stuff. I have requested the packages for rubygem-minitest and rubygem-gemcutter.  rubygem-rubyforge is already available in EPEL. I will keep you posted on status.
Comment 2 Lubomir Rintel 2010-05-05 11:53:56 EDT
Michael, your fault is dragging in a new major version of package (apart from dragging in a ton of new dependencies).

Please do not do this sort of thing in EPEL, push bugfixes only and leave this for fedora.

Thank you for quick reaction though.
Comment 3 Michael Stahnke 2010-05-05 15:11:24 EDT
Putting in new version is not a problem in EPEL, if you maintain compatibility. 

Somehow, I just missed these two deps and am still figuring that part out.  (That system has been re-imaged since then.)   Normally I start with maintaining these packages for my day job and then move them to EPEL once I've been using them a while.  In this case, there is obviously some variable I missed on my work systems vs. a raw EPEL repo.  I am trying to fix it and have requested branches for minitest and gemcutter.
Comment 4 Mark Chappell 2010-09-22 06:57:17 EDT
rubygem-hoe now installs fine, closing off this bug

Note You need to log in before you can comment on or make changes to this bug.