Bug 588381 - Agent doesn't like to auto-upgrade under Windows
Summary: Agent doesn't like to auto-upgrade under Windows
Status: CLOSED NOTABUG
Alias: None
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: All Windows
high
medium vote
Target Milestone: ---
: ---
Assignee: John Sanda
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: jon-sprint10-bugs jon-sprint11-bugs
TreeView+ depends on / blocked
 
Reported: 2010-05-03 15:47 UTC by Corey Welton
Modified: 2014-06-18 18:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-25 21:45:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logfile of attempted upgrade. (133.24 KB, text/plain)
2010-05-03 15:53 UTC, Corey Welton
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1110905 None None None Never

Description Corey Welton 2010-05-03 15:47:56 UTC
Description of problem:
I'm not sure exactly what is happening here, but I've noticed it while managing Windows resources.  When I upgrade my server, all my linux/unix resources upgrade agent just fine, but it is failing in Windows for some reason, not unpacking it to the right place.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1.  Install some older version (release, test build) of JON onto a server and deploy agent to a Windows system to "C:\rhq-agent"
2.  Upgrade server
3.  Return to windows system and see if the agent gets autoupgraded
  
Actual results:
I see the new agent get retrieved, the old agent stuff get deleted and/or moved to rhq-agent-OLD, but the new agent gets unpacked to 'upgrade-<some hash>' and never gets replaced in the old c:\rhq-agent location.

Expected results:

Agent Upgrade works
Additional info:

See attached upgrade log.  Also note the file path.  In this case, the agent had been running from 'update-14371b8'; this is because I have encountered this failure once before and just for the time being, ran the agent from within there.  Note the following:


 Directory of C:\rhq-agent\update-14371b8\rhq-agent-OLD

05/03/2010  08:03 AM    <DIR>          .
05/03/2010  08:03 AM    <DIR>          ..
05/03/2010  08:03 AM    <DIR>          bin
05/03/2010  08:03 AM    <DIR>          conf
05/03/2010  08:03 AM    <DIR>          data
05/03/2010  08:03 AM    <DIR>          lib
05/03/2010  08:03 AM    <DIR>          logs
05/03/2010  08:03 AM    <DIR>          plugins
05/03/2010  08:03 AM    <DIR>          update-56eb99b
               0 File(s)              0 bytes
               9 Dir(s)  132,422,012,928 bytes free

C:\rhq-agent\update-14371b8\rhq-agent-OLD>

"update-56eb99b" is where the newly-downloaded agent upgrade exists -- inside rhq-agent-OLD.  I think all contents of rhq-agent were moved here w/o the agent actually getting installed.

Comment 1 Corey Welton 2010-05-03 15:53:00 UTC
Created attachment 411044 [details]
logfile of attempted upgrade.

Comment 3 John Sanda 2010-06-18 18:46:52 UTC
Corey, the errors in your agent update log look the same as the ones I saw in my log. Did you have any terminals open in the directories being deleted? I did when the agent update failed for me on windows when I was testing bug 601104. The update was unable to delete the directories due to Windows file locking.

I retested the update, making sure I didn't have any terminals open in any subdirectories of rhq-agent, and the update completed without error. You may want to double check that and retest.

Comment 4 John Sanda 2010-06-23 04:32:06 UTC
Corey, based on my previous investigation for bug 601104, I am going to throw this back to you. Please let me know if there is something going on other than the Windows file locking.

Comment 5 Corey Welton 2010-06-25 21:45:01 UTC
QA Closing.


Note You need to log in before you can comment on or make changes to this bug.