Bug 588391 - GFS2: gfs2_block_truncate_page() - don't mark_buffer_dirty() for journaled data files
Summary: GFS2: gfs2_block_truncate_page() - don't mark_buffer_dirty() for journaled da...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5.6
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Steve Whitehouse
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-03 16:04 UTC by Abhijith Das
Modified: 2010-11-09 13:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 09:18:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Abhijith Das 2010-05-03 16:04:45 UTC
The call to mark_buffer_dirty() should be conditional upon it not being a journaled data file. The code in gfs2_block_truncate_page() is copied largely into gfs2_adjust_quota() and this bug was discovered and corrected there in through the patch for bug 555754.

This needs to be fixed here as well.

Comment 1 RHEL Product and Program Management 2010-05-20 12:49:02 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Steve Whitehouse 2010-05-26 09:18:30 UTC
Actually this is correct as it is. Its rather confusing due to the different way in which we treat data and metadata in the journal. Our writepages for jdata knows how to do the right thing, and if we don't mark it dirty then writepages won't ever get called on that page.

Sorry for the confusion.


Note You need to log in before you can comment on or make changes to this bug.