Bug 588423 - [855gm] [drm:i915_gem_execbuffer] *ERROR* i915_gem_do_execbuffer returns -5
[855gm] [drm:i915_gem_execbuffer] *ERROR* i915_gem_do_execbuffer returns -5
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
6.0
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
card_855GM
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 13:32 EDT by Szabo Akos
Modified: 2011-08-17 16:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-17 16:11:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full dmesg output (45.25 KB, text/plain)
2010-05-03 13:32 EDT, Szabo Akos
no flags Details
Xorg X11 log (43.73 KB, text/plain)
2010-05-03 13:33 EDT, Szabo Akos
no flags Details
SMOLT db link to hardware list (74 bytes, text/plain)
2010-05-03 13:34 EDT, Szabo Akos
no flags Details

  None (edit)
Description Szabo Akos 2010-05-03 13:32:23 EDT
Created attachment 411069 [details]
Full dmesg output

Description of problem:

X11 display randomly frozen under install

Version-Release number of selected component (if applicable):
RedHat Enterprise Linux 6.0 Beta

How reproducible:
Always. Just try to graphically install. Usually when I try to select the time zone, the display is frozen.

Steps to Reproduce:
1. Boot from DVD, using graphical install, with, or without the suggested "i915.powersave=0" parameter.
2.Try a normal install
3.The screen randomly stop to respond.
  
Actual results:
The screen frozen, stop to respond.  The mouse pointer working right, but the display content not changing. I can switch to console, and back to X, network is working right, just the X display locked up.

Expected results:
Working X11.

Additional info:
This is an ASUS A3L notebook:
http://www.smolts.org/client/show/pub_b684b09c-afb6-41d8-95ce-3739173efde5

If any further info needed, PLS ask me.
Comment 1 Szabo Akos 2010-05-03 13:33:16 EDT
Created attachment 411071 [details]
Xorg X11 log
Comment 2 Szabo Akos 2010-05-03 13:34:54 EDT
Created attachment 411073 [details]
SMOLT db link to hardware list
Comment 3 Szabo Akos 2010-05-03 13:44:41 EDT
I just found this now, so maybe this report a duplicate of 585542
Comment 5 RHEL Product and Program Management 2010-05-03 15:08:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Matěj Cepl 2010-05-06 09:57:51 EDT
> [drm:i915_gem_execbuffer] *ERROR* i915_gem_do_execbuffer returns -5

looks truly suspicious
Comment 8 Szabo Akos 2010-05-07 03:26:31 EDT
I can produce those error message any time, when I using kms, with intel hardware :(

Do You need any additional info?
Comment 9 Josh 2010-06-01 21:36:04 EDT
I'm experiencing this on my installed rhel6 machine.  It occurs randomly.
Comment 10 Adam Jackson 2010-06-07 13:34:04 EDT
There are several fixes since -19 that could address this, not least being watermark setup for 855.  Please try again with kernel 2.6.32-34 or later.
Comment 11 Josh 2010-06-09 15:28:26 EDT
(In reply to comment #10)
> There are several fixes since -19 that could address this, not least being
> watermark setup for 855.  Please try again with kernel 2.6.32-34 or later.    

Would love to!  Will it be made available before GA?
Comment 12 Adam Jackson 2010-06-23 12:32:36 EDT
I'm told beta2 will be on RHN and FTP.
Comment 13 Szabo Akos 2010-07-02 09:46:39 EDT
(In reply to comment #10)
> There are several fixes since -19 that could address this, not least being
> watermark setup for 855.  Please try again with kernel 2.6.32-34 or later.    

I can't try easily with RH, but I use fedora. With kernel-2.6.33.5-124.fc13.i686 I can use X, but no xvid, with kernel-2.6.35-0.23.rc3.git6.fc14.i686 everything working right!

Which kernel will be in final release? :D
My versions:
kernel-2.6.35-0.23.rc3.git6.fc14.i686
xorg-x11-drv-intel-2.12.0-1.fc14.i686
xorg-x11-server-common-1.8.0-7.fc14.i686
libdrm-2.4.21-2.fc14.i686

If You want, I can test with public RH beta, but it's need more time :(
Comment 14 RHEL Product and Program Management 2010-07-15 10:59:10 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 16 RHEL Product and Program Management 2011-01-07 11:00:58 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 17 RHEL Product and Program Management 2011-02-01 01:07:02 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 18 RHEL Product and Program Management 2011-02-01 13:19:23 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 19 RHEL Product and Program Management 2011-04-03 22:34:56 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 20 Adam Jackson 2011-08-17 16:11:46 EDT
The DRM code in RHEL 6.2 contains all the intel gpu-related fixes from the Fedora kernel mentioned in comment #13 (and many more besides).

Closing this bug.  Please reopen if this issue recurs with 6.2 or later.

Note You need to log in before you can comment on or make changes to this bug.