Bug 588430 - Target cpu appended to kernel release changes expected output from 'uname -r'
Summary: Target cpu appended to kernel release changes expected output from 'uname -r'
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Prarit Bhargava
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: 846704
TreeView+ depends on / blocked
 
Reported: 2010-05-03 17:44 UTC by Phil Perry
Modified: 2015-03-23 14:08 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-23 14:08:05 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Phil Perry 2010-05-03 17:44:58 UTC
Description of problem:
Due to target cpu being appended to the kernel release, the expected output from 'uname -r' now has the target cpu appended.

This has the potential to break any scripts etc using the output from 'uname -r'.

Version-Release number of selected component (if applicable):
kernel-2.6.32-19.el6

How reproducible:
Always

Steps to Reproduce:
1. uname -r
2.
3.
  
Actual results:

$ uname -r
2.6.32-19.el6.i686

Expected results:

$ uname -r
2.6.32-19.el6

Additional info:

See here for a discussion on the RHEL6beta mailing list:
https://www.redhat.com/mailman/private/rhelv6-beta-list/2010-April/msg00162.html

See here for where this "feature" was introduced:
https://bugzilla.redhat.com/show_bug.cgi?id=197065

Comment 3 RHEL Program Management 2010-05-03 19:08:31 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 6 RHEL Program Management 2010-07-15 14:39:54 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 7 RHEL Program Management 2011-10-07 15:01:32 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 8 Prarit Bhargava 2015-03-23 14:08:05 UTC
We've gone almost the entire release cycle with no customers complaining, so I'm closing this as WONTFIX.

P.


Note You need to log in before you can comment on or make changes to this bug.