Bug 58844 - yppasswd and/or rpc.yppasswdd do not work
Summary: yppasswd and/or rpc.yppasswdd do not work
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ypserv   
(Show other bugs)
Version: 6.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-25 18:49 UTC by Robert Franchisseur
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 15:54:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Franchisseur 2002-01-25 18:49:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-6.2.12 i686)

Description of problem:
Running yppasswd on either a client or a NIS server, I get:

Error while changing the NIS password.
The NIS password has not been changed on circe.ups-tlse.fr.

/var/log/messages  on the server says:

Jan 25 19:36:29 circe rpc.yppasswdd[8288]: update robert (uid=500) from host
130.120.88.99 rejected
Jan 25 19:36:29 circe rpc.yppasswdd[8288]: now < minimum age for `robert'




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.yppasswd
2.
3.
	

Additional info:

Linux circe 2.2.19-6.2.12 #1 Fri Oct 26 14:03:47 EDT 2001 i686 unknown
with all patches

ypserv-1.3.9-3
yp-tools-2.4-1
ypbind-1.7-0.6.x

Comment 1 Florian La Roche 2002-03-10 12:24:04 UTC
It is possible to define a minimum time to gain change the password and
similar things. Seems this has been done on this server?

cu,

Florian La Roche


Comment 2 Robert Franchisseur 2002-03-22 20:03:11 UTC
No, but I found that the problem is when using "kuser" to create an account. I
now use "linuxconf"
and it is OK.

Comment 3 Alexander Larsson 2002-03-26 15:54:16 UTC
If you create the account with kuser you can't change the password with
yppasswd, but you can if you create the account with linuxconf?

Can you change the password using just "passwd"?

Comment 4 Alexander Larsson 2002-03-26 22:37:09 UTC
I was not able to reproduce this in the latest versions of yp + kuser, and this
seems to have been more of a kuser bug. Closing.


Note You need to log in before you can comment on or make changes to this bug.