Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 588440 - [abrt] crash in esc-1.1.0-13.el6: Process /usr/lib/esc-1.1.0/esc was killed by signal 6 (SIGABRT)
[abrt] crash in esc-1.1.0-13.el6: Process /usr/lib/esc-1.1.0/esc was killed b...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: esc (Show other bugs)
6.0
i686 Linux
low Severity medium
: rc
: ---
Assigned To: Jack Magne
Chandrasekar Kannan
abrt_hash:697da5090284295df9f8e22ed6d...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 14:00 EDT by Arthur Enright
Modified: 2015-01-04 18:42 EST (History)
5 users (show)

See Also:
Fixed In Version: esc-1.1.0-21.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 15:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (26.73 KB, text/plain)
2010-05-03 14:00 EDT, Arthur Enright
no flags Details

  None (edit)
Description Arthur Enright 2010-05-03 14:00:28 EDT
abrt 1.0.7 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: ./esc
comment: Log into cold booted box using username/pass credentials, Log out, Log back in with username/pass credentials and escd errors reporting that there is another instance running and consumes 100% CPU until forcefully killed
component: esc
executable: /usr/lib/esc-1.1.0/esc
kernel: 2.6.32-19.el6.i686
package: esc-1.1.0-13.el6
rating: 4
reason: Process /usr/lib/esc-1.1.0/esc was killed by signal 6 (SIGABRT)
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)

How to reproduce
-----
1. Log into cold booted box using username/pass credentials
2. Log out
3. Log back in with username/pass credentials and escd errors reporting that there is another instance running and consumes 100% CPU until forcefully killed
Comment 1 Arthur Enright 2010-05-03 14:00:30 EDT
Created attachment 411082 [details]
File: backtrace
Comment 3 Arthur Enright 2010-05-03 14:20:29 EDT
Closed as the tool crashed before I could finish loading debug-info packages, re-submitting new bug
Comment 4 RHEL Product and Program Management 2010-05-03 15:08:34 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Asha Akkiangady 2010-05-03 17:28:26 EDT
Tested this on Rhel6 x86_64 desktop with 'esc-1.1.0-21.el6' and 'pcsc-lite-1.5.2-4.el6', did not see errors reporting that there is another esc instance running. 


Arthur, can you update esc and pcsc-lite packages to the latest ones and try this test?
thanks,
Asha
Comment 7 Arthur Enright 2010-05-04 12:39:09 EDT
Asha,

I'm using the rhel-beta repo:

[rhel-beta]
name=Red Hat Enterprise Linux $releasever Beta - $basearch
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/$basearch/os/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

[rhel-beta-optional]
name=Red Hat Enterprise Linux $releasever Beta (Optional) - $basearch
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/optional/$basearch/os/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

[rhel-beta-source]
name=Red Hat Enterprise Linux $releasever Beta - $basearch - Source
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/source/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

[rhel-beta-optional-source]
name=Red Hat Enterprise Linux $releasever Beta (Optional) - $basearch - Source
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/optional/source/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

[rhel-beta-debuginfo]
name=Red Hat Enterprise Linux $releasever Beta - $basearch - Debuginfo
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/$basearch/debuginfo/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

[rhel-beta-optional-debuginfo]
name=Red Hat Enterprise Linux $releasever Beta (Optional) - $basearch - Debuginfo
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/optional/$basearch/debuginfo/
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2

I have all the updates from this repo, is there a newer repo I can be pulling updates from?

Unfortunately, per customer requirements I'm stuck using the 32-bit release.

Thanks,
-Art
Comment 8 Jack Magne 2010-05-04 18:52:15 EDT
The first comment mentions the "esc is already running" problem. I think perhaps the original bug was caused by this problem. Since we have addressed this issue another bug# 582833, I suspect this issue will go away as well.
Comment 9 Jack Magne 2010-05-25 16:16:16 EDT
Marking as modified so Asha can take another look and attempt to duplicate.
Comment 11 Asha Akkiangady 2010-06-01 18:00:21 EDT
Tested on Rhel 6 (i686 and x86_64) with esc-1.1.0-21.el6, pcsc-lite-1.5.2-4.el6 and gdm-2.28.2-5.el6. Logout and login back as a regular user did not show escd errors reporting that there is another esc instance running. No CPU shoot up issues found. 

Marking the bug verified.
Comment 12 releng-rhel@redhat.com 2010-07-02 15:04:28 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.