Bug 58845 - /usr/bin/mozilla script doesn't locate IBM's JRE
/usr/bin/mozilla script doesn't locate IBM's JRE
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-25 14:23 EST by Manfred Hollstein
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-05 04:55:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manfred Hollstein 2002-01-25 14:23:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226

Description of problem:
The directory structure of the IBM JRE (IBMJava2-JRE-1.3-9.0 on Red
Hat Linux 7.2) is different compared to Sun's jre (jre-1.3.1_01-fcs). 
The start script /usr/bin/mozilla, which is contained in Mozilla's
RPMs for Linux, tries to locate the "java" script based on where the
plugin is stored; while this works OK for the Sun version, it doesn't 
for IBM's because IBM have the plugin as well as the "java" script
stored in the *same* directory. This is compensated by the following
patch (please note that this patch is relative to Mozilla's current
versions, ie. 0.9.5-0.9.7!):

--- ./usr/bin/mozilla.orig      Fri Oct 12 09:01:19 2001
+++ ./usr/bin/mozilla   Thu Nov  8 12:15:32 2001
@@ -81,22 +81,14 @@ function set_jvm_vars() {
 
     JVM_BASE=`basename $JVM_LINK`
     JVM_DIR=`echo $JVM_LINK | sed -e s/$JVM_BASE//g`
-    JVM_DIR=${JVM_DIR}../../../bin/
-
-    # make sure it was found
-    if [ -z "$JVM_DIR" ]; then
-        return
-    fi
-
-    # does it exist?
-    if [ ! -d "$JVM_DIR" ]; then
-        return
-    fi
-
     JVM_COMMAND=$JVM_DIR/java
-    # does the command exist?
-    if [ ! -r "$JVM_COMMAND" ]; then
-       return
+    if [ ! -r $JVM_COMMAND ]; then
+       JVM_DIR=${JVM_DIR}../../../bin/
+       JVM_COMMAND=$JVM_DIR/java
+       # does the command exist?
+       if [ ! -r "$JVM_COMMAND" ]; then
+           return
+       fi
     fi
 
     # export this temporarily - it seems to work with old and new

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install IBM's JRE
2.Start /usr/bin/mozilla
	

Actual Results:  No Mozilla window appears :-(

Expected Results:  Mozilla should start normally.

Additional info:
Comment 1 Manfred Hollstein 2002-05-05 04:55:50 EDT
This is integrated into the original sources at mozilla.org. The report can be
closed now.
Comment 2 Christopher Blizzard 2002-05-06 11:22:09 EDT
Ahh, so it is.

Note You need to log in before you can comment on or make changes to this bug.