Bug 58846 - Segmentation fault during compiling
Summary: Segmentation fault during compiling
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.2
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-25 19:29 UTC by Kevin Battaile
Modified: 2007-04-18 16:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 19:11:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Battaile 2002-01-25 19:29:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 (Macintosh; U; PPC)

Description of problem:
I was compiling the package EMBOSS using gcc-2.96-98 and got the following error: 

ajfeat.c: In function `featTagSpecial':
ajfeat.c:6852: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [ajfeat.lo] Error 1
make[1]: Leaving directory `/usr/local/EMBOSS-2.2.0/ajax'
make: *** [all-recursive] Error 1

I have compiled this package on a different system (AMD K6-2, RH 7.2, but no 
updates) without problems. When I attempt to re-compile, the system crashes.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:

Comment 1 Jakub Jelinek 2002-01-28 11:25:08 UTC
Unless you get the same error when rerunning the same gcc command line
on the same source file, it is likely a hardware problem (or kernel problem),
especially if you write that the system crashes.
If you can reproduce it, please attach here the preprocessed source file
(see gcc -save-temps option) and full command line used to reproduce it.


Note You need to log in before you can comment on or make changes to this bug.