This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 588462 - firstboot doesn't check for weak password in non-live install
firstboot doesn't check for weak password in non-live install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-users (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-05-03 14:51 EDT by Andre Robatino
Modified: 2010-05-05 03:19 EDT (History)
3 users (show)

See Also:
Fixed In Version: system-config-users-1.2.97-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-05 03:19:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2010-05-03 14:51:04 EDT
Description of problem:
After doing a non-live install, during firstboot, if a weak password is entered, there is no warning.  There is a warning for the root password, and during a live install, there is a warning for both the root and firstboot passwords.

Version-Release number of selected component (if applicable):
system-config-users-1.2.96-1.fc13.noarch

How reproducible:
always
Comment 1 Nils Philippsen 2010-05-03 14:59:04 EDT
s-c-users wrongly determined whether to require cracklib-python vs. cracklib. I've just fixed this in the upstream repository:

http://git.fedorahosted.org/git?p=system-config-users.git;a=commitdiff;h=ae6e023681d317bfa4764db7cb8e9ca09949d09a

Setting F13Blocker since this fix needs to be on the media, otherwise it won't have any effect in firstboot.
Comment 2 Fedora Update System 2010-05-03 15:15:42 EDT
system-config-users-1.2.97-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-users-1.2.97-1.fc13
Comment 3 Fedora Update System 2010-05-03 15:16:33 EDT
system-config-users-1.2.97-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/system-config-users-1.2.97-1.fc12
Comment 4 James Laska 2010-05-03 20:43:30 EDT
MODIFIED, awaiting bodhi karma
Comment 5 Adam Williamson 2010-05-04 19:52:34 EDT
update looks good, can you please submit to stable ASAP? Thanks.
Comment 6 Fedora Update System 2010-05-04 19:55:15 EDT
system-config-users-1.2.97-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-users'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-users-1.2.97-1.fc13
Comment 7 Fedora Update System 2010-05-05 03:19:27 EDT
system-config-users-1.2.97-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.