Bug 588485 - AttributeError: 'NoneType' object has no attribute 'format'
Summary: AttributeError: 'NoneType' object has no attribute 'format'
Keywords:
Status: CLOSED DUPLICATE of bug 573492
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:d7a63b9a50bb6a109...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-03 19:41 UTC by James Laska
Modified: 2013-09-02 06:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-03 20:01:10 UTC
Type: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (275.32 KB, text/plain)
2010-05-03 19:41 UTC, James Laska
no flags Details
Attached traceback automatically from anaconda. (274.30 KB, text/plain)
2010-05-03 19:50 UTC, James Laska
no flags Details
Attached traceback automatically from anaconda. (367.27 KB, text/plain)
2010-05-10 14:01 UTC, James Laska
no flags Details

Description James Laska 2010-05-03 19:41:20 UTC
The following was filed automatically by anaconda:
anaconda 13.39 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/yuminstall.py", line 839, in mirrorFailureCB
    dev.format.mountpoint = self.tree
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 297, in _failure
    action = cb(cb_obj, *args, **kwargs) or {}
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 402, in _mirror_try
    self._failure(gr, obj)
  File "/usr/lib/python2.6/site-packages/urlgrabber/mirror.py", line 408, in urlgrab
    return self._mirror_try(func, url, kw)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 810, in _getFile
    size=size
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 986, in _getFileRepoXML
    size=102400) # setting max size as 100K
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1201, in _commonLoadRepoXML
    result = self._getFileRepoXML(local, text)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1374, in _groupLoadRepoXML
    if self._commonLoadRepoXML(text):
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1399, in _loadRepoXML
    return self._groupLoadRepoXML(text, self._mdpolicy2mdtypes())
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1409, in _getRepoXML
    self._loadRepoXML(text=self)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1417, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 1227, in _check_db_version
    repoXML = self.repoXML
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 223, in _check_db_version
    return repo._check_db_version(mdtype)
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 164, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 279, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 564, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 527, in doSackSetup
    return self._getSacks(archlist=archlist, thisrepo=thisrepo)
  File "/usr/lib/anaconda/yuminstall.py", line 1220, in <lambda>
    self.__withFuncDo(anaconda, lambda r: self.ayum.doSackSetup(thisrepo=r.id),
  File "/usr/lib/anaconda/yuminstall.py", line 1247, in __withFuncDo
    fn(repo)
  File "/usr/lib/anaconda/yuminstall.py", line 1221, in doSackSetup
    thisrepo=thisrepo, fatalerrors=fatalerrors)
  File "/usr/lib/anaconda/iw/task_gui.py", line 47, in setupRepo
    anaconda.backend.doSackSetup(anaconda, thisrepo=repo.id, fatalerrors=False)
  File "/usr/lib/anaconda/iw/task_gui.py", line 368, in run
    setupRepo(self.anaconda, newRepoObj):
  File "/usr/lib/anaconda/iw/task_gui.py", line 538, in _addRepo
    if dialog.run() in [gtk.RESPONSE_CANCEL, gtk.RESPONSE_DELETE_EVENT]:
AttributeError: 'NoneType' object has no attribute 'format'

Comment 1 James Laska 2010-05-03 19:41:24 UTC
Created attachment 411100 [details]
Attached traceback automatically from anaconda.

Comment 2 James Laska 2010-05-03 19:45:05 UTC
= Steps to reproduce =

1. Boot the netinst.iso of Fedora 13 Final TC1, boot with "askmethod"
2. Choose a pre-existing partition containing a DVD ISO and images/install.img file.
3. Proceed with installation
4. At reposetup screen, attempt to add an http package repository (per instructions at https://fedoraproject.org/wiki/QA:Testcase_Additional_Http_Repository)

Crash!

Comment 3 James Laska 2010-05-03 19:50:14 UTC
Created attachment 411104 [details]
Attached traceback automatically from anaconda.

Comment 4 Chris Lumens 2010-05-03 20:01:10 UTC

*** This bug has been marked as a duplicate of bug 573492 ***

Comment 5 James Laska 2010-05-10 14:01:21 UTC
Created attachment 412848 [details]
Attached traceback automatically from anaconda.


Note You need to log in before you can comment on or make changes to this bug.