Bug 588494 - use proper typing with retransmit buffer
Summary: use proper typing with retransmit buffer
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
(Show other bugs)
Version: 5.5
Hardware: All Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Steven Dake
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks: 588896 588897
TreeView+ depends on / blocked
 
Reported: 2010-05-03 19:56 UTC by Steven Dake
Modified: 2016-04-26 14:45 UTC (History)
5 users (show)

Fixed In Version: openais-0.80.6-18.el5
Doc Type: Bug Fix
Doc Text:
The retransmit list is now properly-typed so as not to confuse the compiler.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 23:56:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix the problem (364 bytes, patch)
2010-05-03 19:58 UTC, Steven Dake
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0100 normal SHIPPED_LIVE openais bug fix update 2011-01-12 17:21:13 UTC

Description Steven Dake 2010-05-03 19:56:42 UTC
Description of problem:
The current typing is a pointer to an array of pointers for the retransmit storage area.  Instead we need a pointer to a buffer area.

Version-Release number of selected component (if applicable):
openais-0.80.6

How reproducible:
can't reproduce failure

Steps to Reproduce:
1.
2.
3.
  
Actual results:
pointer not pointing to correct area

Expected results:
pointer should point to correct area

Additional info:

Comment 1 Steven Dake 2010-05-03 19:58:51 UTC
Created attachment 411108 [details]
patch to fix the problem

Comment 8 Douglas Silas 2011-01-11 23:17:15 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The retransmit list is now properly-typed so as not to confuse the compiler.

Comment 10 errata-xmlrpc 2011-01-13 23:56:40 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0100.html


Note You need to log in before you can comment on or make changes to this bug.