Bug 588498 - Backtrace in clearpart_gui when only uninitialized disks are found
Backtrace in clearpart_gui when only uninitialized disks are found
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
anaconda_trace_hash:eddb067acb4d83d22...
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-05-03 16:07 EDT by James Laska
Modified: 2013-09-02 02:48 EDT (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.40-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 585105
Environment:
Last Closed: 2010-05-05 21:31:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2010-05-03 16:07:08 EDT
While attempting to work around bug#588493 (Unable to select local BIOS RAID drive as boot drive), I ran into this previously filed RHEL6 anaconda bug.

anaconda 13.39 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/iw/cleardisks_gui.py", line 146, in getScreen
    self.bootDisk = sorted(names, self.anaconda.storage.compareDisks)[0]
  File "/usr/lib/anaconda/gui.py", line 1393, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1314, in nextClicked
    self.setScreen ()
IndexError: list index out of range

Local variables in innermost frame:
xml: <gtk.glade.XML object at 0x7fc0efb6fdc0 (PyGladeXML at 0x2cbdcc0)>
self: <ClearDisksWindow.ClearDisksWindow instance at 0x7fc10bc500e0>
disks: []
names: []
anaconda: <__main__.Anaconda object at 0x7fc10441cf10>

See full traceback details in attachment#411109 [details]

This was a rather forward partitioning back/forward interaction.  If the patch already fixed in RHEL6 is tested and isolated, I'd like to request pulling this into F13.
Comment 1 Hans de Goede 2010-05-04 03:33:17 EDT
Ok, I'll cherry pick the fix into f13-branch.
Comment 2 Hans de Goede 2010-05-04 04:55:00 EDT
This should be fixed in anaconda-13.40-1, moving to modified.
Comment 3 Adam Williamson 2010-05-04 19:53:20 EDT
james, can you test with the updates.img? Thanks.
Comment 4 James Laska 2010-05-04 20:03:08 EDT
I'll try, but I suspect not, this involved hitting a previous bug, then going through a few iterations of hitting Back (and Next) a few times.  I'll try to test tomorrow.  If I'm not able to reproduce the original problem, we can move this along.
Comment 5 Fedora Update System 2010-05-05 01:16:17 EDT
anaconda-13.40-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/anaconda-13.40-1.fc13
Comment 6 Fedora Update System 2010-05-05 03:22:48 EDT
anaconda-13.40-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/anaconda-13.40-1.fc13
Comment 7 James Laska 2010-05-05 08:43:05 EDT
I'm not able to reproduce this failure using anaconda-13.39-1 + an updates.img which includes the fix.
Comment 8 Adam Williamson 2010-05-05 12:58:29 EDT
We should now be able to confirm that this bug is fixed using the images here:

http://alt.fedoraproject.org/pub/alt/stage/13.0505/Fedora/i386/os/images/

if we have not yet confirmed the fix, can anyone able to reproduce this bug please test with one of those images and check that the bug is fixed? Thanks.
Comment 9 James Laska 2010-05-05 13:48:22 EDT
I'm not able to reproduce this failure using anaconda-13.40-1 from the URL in comment#8
Comment 10 Adam Williamson 2010-05-05 21:31:33 EDT
okay, let's close it then.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Fedora Update System 2010-05-06 02:54:53 EDT
anaconda-13.40-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.