Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 588508 - Missing development headers and linker libraries of libusal
Missing development headers and linker libraries of libusal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cdrkit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 16:27 EDT by John Paul Adrian Glaubitz
Modified: 2011-03-28 11:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: cdrkit-1.1.11-4.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-28 11:06:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch proposed (858 bytes, patch)
2011-02-18 08:16 EST, Honza Horak
no flags Details | Diff
new spec file proposed (11.62 KB, application/octet-stream)
2011-02-18 08:18 EST, Honza Horak
no flags Details
Simple test of usal library. (372 bytes, text/plain)
2011-02-24 09:26 EST, Honza Horak
no flags Details

  None (edit)
Description John Paul Adrian Glaubitz 2010-05-03 16:27:46 EDT
Hi,

the current upstream source of cdrkit misses an install rule for the headers and linker libraries (.a-files) of libusal. It is therefore not possible to compile own code which links against libusal. Since libusal is a highly flexible and portable SCSI library, it's highly desirable to have that included.

In fact, when building and installing the original cdrtools sources, the appropriate headers and libraries for libscg are installed and can therefore be used to build custom applications which use this SCSI library. It seems that the appropriate install rules were lost during the fork process.

Regards,

Adrian
Comment 1 Fedora Admin XMLRPC Client 2011-01-10 08:23:20 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Honza Horak 2011-01-24 10:53:07 EST
I've forwarded this request to cdrkit upstream (http://lists.alioth.debian.org/pipermail/debburn-devel/2011-January/000825.html).
Comment 3 Jörg Schilling 2011-01-24 18:19:45 EST
I recommend people who like to use this library interface to use the maintained original software instead of a questionable fork that is dead since 4 years.
Comment 4 Honza Horak 2011-01-31 03:58:36 EST
Cdrkit is still alive. The last version was released in October 2010 and development continues further.
Comment 5 Jörg Schilling 2011-01-31 09:37:27 EST
cdrkit uses a variant of libscg that is known to be full of bugs. Since May 2007, nothing has been done on the code, so we can safely call it dead.

There is no development in the fork, it did not even ever try to fix one of the eprox. 100 well known bugs.

Redhat just removes the bug entries from it's database without fixing the bugs. They are still there....
Comment 6 Honza Horak 2011-02-18 08:16:37 EST
Created attachment 479497 [details]
patch proposed

A patch is proposed. For more info see the next comment.
Comment 7 Honza Horak 2011-02-18 08:18:09 EST
Created attachment 479498 [details]
new spec file proposed

A new spec file is proposed with the patch above. It adds a new subpackage libusal-devel in order to install libusal.a and header files.

libusal.a is installed into /usr/lib or /usr/lib64, libusal/usal/*.h files are installed into /usr/include/usal/.

Adrian, could you try the patch and spec file to see, if it fulfills your requirments?
Comment 8 Honza Horak 2011-02-24 08:37:57 EST
Comment on attachment 479497 [details]
patch proposed

this patch is obsolete
Comment 9 Honza Horak 2011-02-24 08:38:21 EST
Comment on attachment 479498 [details]
new spec file proposed

this spec file is obsolete
Comment 10 Honza Horak 2011-02-24 09:23:19 EST
A new build is proposed on http://koji.fedoraproject.org/koji/buildinfo?buildID=230556

In this build libusal.a and librols.a are installed together with libusal's header files. librols.a contains some general functions used by libusal.a.

I'm planning to push this build into F15, but not F14 or older any more.
Comment 11 Honza Horak 2011-02-24 09:26:55 EST
Created attachment 480770 [details]
Simple test of usal library.

This is a simple test of libusal. You can compile it using 
  gcc -o usaltest usaltest.c -lusal -lrols

It should print a status of /dev/cdrom to stdout. For example: 
  status: 0x0 (GOOD STATUS)
Comment 12 Fedora Update System 2011-02-28 05:55:43 EST
Package cdrkit-1.1.11-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cdrkit-1.1.11-4.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/cdrkit-1.1.11-4.fc15
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2011-03-01 01:48:41 EST
cdrkit-1.1.11-4.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cdrkit'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/cdrkit-1.1.11-4.fc15

Note You need to log in before you can comment on or make changes to this bug.