Bug 58852 - /etc/hosts entries not honoured before DNS lookups
/etc/hosts entries not honoured before DNS lookups
Status: CLOSED DUPLICATE of bug 57998
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-01-25 16:24 EST by Jeremy Laidman
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-01-25 16:24:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeremy Laidman 2002-01-25 16:24:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
Using telnet or ssh to a host which is named in /etc/hosts causes the
client to perform a DNS lookup for the name.  This includes
"localhost".  host.conf says "order hosts, bind"; nsswitch.conf says
for hosts: "files nisplus dns".  /etc/hosts says
" localhost.localdomain localhost".  strace and ltrace tell
me that it's using lib_files, then lib_nisplus, then lib_dns.

When I take dns out of nsswitch, it resolves quickly.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.type "telnet localhost" - takes a long time to respond
2.copy telnet from (say) mandrake 7.2, same command comes back straight away

Actual Results:  slow lookup with DNS traffic for entries in /etc/hosts

Expected Results:  instant lookup for entries in /etc/hosts

Additional info:
Comment 1 Jakub Jelinek 2002-01-27 05:25:08 EST

*** This bug has been marked as a duplicate of 57998 ***

Note You need to log in before you can comment on or make changes to this bug.