Bug 588540 - The root for the previously installed system was not found; upgrading f12 to f13 (branch)
The root for the previously installed system was not found; upgrading f12 to ...
Status: CLOSED DUPLICATE of bug 585563
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 17:53 EDT by Iván Jiménez
Modified: 2010-05-03 17:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 17:57:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback obtained wit killall -USR2 anaconda (156.00 KB, text/plain)
2010-05-03 17:53 EDT, Iván Jiménez
no flags Details
ks used (271 bytes, text/plain)
2010-05-03 17:54 EDT, Iván Jiménez
no flags Details
grub.conf used (1.38 KB, text/plain)
2010-05-03 17:57 EDT, Iván Jiménez
no flags Details

  None (edit)
Description Iván Jiménez 2010-05-03 17:53:51 EDT
Created attachment 411142 [details]
traceback obtained wit killall -USR2 anaconda

Description of problem:
I'm trying to upgrade from f12 to f13 (branch) but there appears an error saying "The root for the previously installed system was not found" (like in bug 587185). My current partition layout is:

Disk /dev/sda: 160.0 GB, 160000000000 bytes
255 heads, 63 sectors/track, 19452 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x38000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1           7       56196    6  FAT16 (dell util)
/dev/sda2               8         399     3148740    c  W95 FAT32 (LBA) (rescue)
/dev/sda4             426       19452   152834377+   5  Extended
/dev/sda5             426       16361   128000000   83  Linux (home)
/dev/sda6   *       16361       17891    12287999+  83  Linux (root)
/dev/sda7           17891       18400     4095999+  83  Linux (swap)

I first used preupgrade but because of insufficient space in boot partition (it was sda3) I relocated /boot to root partition (sda6) and deleted sda3. When I rebooted to upgrade I got the error. After, I used vmlinuz, initrd.img and install.img from a f13 repo and got the same error; I also tested the same from a f12 repo and identical result (that's why I'm reporting it against anaconda).

For some reason anaconda mounts sda5 (DEBUG anaconda: isys.py:mount()-
going to mount /dev/sda5 on /mnt/sysimage as ext4 with options ro) and then fails (DEBUG anaconda: No upgrade root was found), shouldn't it also try to mount sda6? Interestingly, if I do "mount LABEL=rootfs /tmp/mnt" from anaconda's runtime shell, it works fine.

Version-Release number of selected component (if applicable):
anaconda 13.39

How reproducible:
Always
Comment 1 Iván Jiménez 2010-05-03 17:54:54 EDT
Created attachment 411143 [details]
ks used
Comment 2 Chris Lumens 2010-05-03 17:57:32 EDT

*** This bug has been marked as a duplicate of bug 585563 ***
Comment 3 Iván Jiménez 2010-05-03 17:57:44 EDT
Created attachment 411145 [details]
grub.conf used

I manually boot Upgrade to Fedora 13 (Branch)

Note You need to log in before you can comment on or make changes to this bug.